Exchange 2007 rules quota

Phesant123
Phesant123 used Ask the Experts™
on
Hello,

Regarding the rules quota in Exchange 2007, the default is set to 64KB. This needed to be increased on a mailbox so I ran the powershell command set-mailbox <mailbox name> -RulesQuota:256KB and it worked in that when you run the get command you can see that the rules quota has changed on the mailbox to 256KB, but when I log into the mailbox in question and try to add or enable another rule I still get the error....

'One or more rules cannot be updated to Microsoft Exchange and have been deactivated. This could be because some of the parameters are not supported, or there is insufficient space to store all of your rules.'

The only thing I can think that is causing the problem is that the mailbox in question was created on an E2K3 environment and the migrated over to E2K7, maybe there is some old E2K3 setting still there, I don't know.

Does anyone know of a solution to this?

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Shivkumar SharmaOperations Delivery Manager

Commented:
Restart Ms-exchange System Attendaant and also Ms-exchange information store services.

Author

Commented:
restarting the system attendant and information store did not solve the issue.

Commented:

If you wish to have unlimited amount of rules, take a look at commercial Exchange utilities like Mapilab Rules or SpamMover.

Regards,
Victor
System and Storage Engineer
Commented:
If you see this error message when trying to add rules in Outlook:
:One or more rules could not be uploaded to Exchange server and have been deactivated. This could be because some of the parameters are not supported or there is insufficient space to store all your rules.

Check out this KB article for details on the problem: http://support.microsoft.com/kb/886616/en-us

By default Exchange 2007 rules size limit is 64KB. It may be that 64KB is not enough to contain all your rules – here's how you check your settings:

[PS] C:\>get-mailbox | Select RulesQuota
RulesQuota
----------
64KB

You can’t change that value using the GUI, so I made the change via the Exchange Powershell:
[PS] C:\>set-mailbox -RulesQuota 256kb

[PS] C:\>get-mailbox | Select RulesQuota
RulesQuota
----------
256KB

Now try to add your rules again - the problem should likely be resolved. Still, try to keep the names of your rules as low as possible.


Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial