Exchange 2007 - Some services don't start on reboot

Mitzysman
Mitzysman used Ask the Experts™
on
running exchange 2007 on Windows 2003

the server is a DC

when i reboot the following services don't restart automatically.

- Information Store
- Service Host
- System Attendant
- Transport

I tried some things mentioned in KB940845 with no luck.  Any ideas
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Awarded 2009
Top Expert 2010

Commented:
What errors are in the event log?

if the server is a DC is it also a global catalogue server?
Again follow http://support.microsoft.com/kb/940845.

To configure a service to restart automatically, follow these steps:
Open the properties of the Microsoft Exchange System Attendant in the Services MMC snap-in.
Click Recovery.
In the First failure box, click Restart the Service to restart the service on the first failure.
In the Restart Service After box, type 3 so that the service restarts after three minutes.
Repeat steps 1 to 4 for each Exchange Server service that does not start.

Note You will not have to modify some newer Exchange Server services. For example, the Microsoft Exchange Transport service contains restart logic.

Author

Commented:
I tried method 4 (KB940845) last night - used 4 minuetes,  no luck

then I tried putting all 4 services dependent on SNMP - which seems to be the last service to come up - no luck

then I tried Method 2 again - no luck either

Services will always start manually - maybe there is somethign that will kick off a bunch of net starts

I think I need a different approach
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
i found a solution - i had to add a secondary dns to the exchange server.  I did it at the network card level and in exchange.  Not sure which one did the trick but it's definately dns related.  

thanks for all the suggestions.
Awarded 2009
Top Expert 2010

Commented:
Glad you got it sorted.
Can you explain what you did?
Will help me and other experts along with other browsers of the site in the future
Exchange Management Console / Server Configuration (root) / double-click server name / Internal DNS Lookups

They were using  "Use these DNS Servers" - the ip listed was the exchange server itselft.

I put a secondary DNS server address - pointing to another DC at the site.

i did the same thing on the nework card in the control panel.

Seems that you can just do it at the network card level and they tell exchange to "Use network Card DNS settings"

rebooted 2 times and it works great.

Awarded 2009
Top Expert 2010

Commented:
accept comment ID: http:#26457947
or PAQ Refund
Awarded 2009
Top Expert 2010

Commented:
Not an obvious fix because it's unusual for it to be set in here

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial