DNS isn't working on a new dc installation of Server 2008 R2

mark-199
mark-199 used Ask the Experts™
on
I have recently setup a new virtualised test environment (Hyper-V) based on Server 2008 R2.
Before that I had a virtual Server 2003 network running on the same server.
This is a breakdown of the hardware used in my test environment:
* HP ProLiant 150 G5
* The server has three NICs (one dedicated management NIC along with two separate NICs)
* two switches, one connected to the Office LAN for Management, the other to a separate ADSL line (Cisco 5505 firewall & Zyxel P-660-H D1).

I installed Server 2008R2 and followed these steps:
* Assigned a static IP address, class C subnet mask and gateway address
* Pointed the DNS server to itself
* Pointed the WINS server to itself
* Disabled IPV6 (I had it initially enabled)
* Installed the WINS feature
* Installed AD & DNS
* Created a reverse lookup zone with a pointer record to point to itself
* Installed DHCP

* Installed a virtualised Windows 7 workstation

* Created a virtual network with both the DC & workstation connected to

This is what is happening:
* I can browse to any websites using IP addresses
* I can browse www.bbc.co.uk by name (the only website bizarrely)
* I can ping the Windows 7 workstation by name
* DHCP works fine
* I can connect to the firewall and router from the DC

When I power up my Server 2003 DC VHD, everything including DNS works fine.
I compared the DNS setup of my two DCs side by side and couldn't really find much difference. That being said, the folder structure in Server 2003 DNS is slightly different from that of 2008R2.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
IT Manager
Commented:
Had a similar problems. DNS worked fine on R2 if I used forwarders but would fail intermittently on root hints.

I found tons of other similar complaints and it seems to be with EDNS settings (http://weblogs.asp.net/owscott/archive/2009/09/15/windows-server-2008-r2-dns-issues.aspx).

Try to disable EDNS and see if it helps
Top Expert 2012

Commented:

Author

Commented:
Thank you brwwiggins- it works! I cannot believe that this isn't more widely publicised.
Dariusq, unfortunately your suggestion didn't solve the problem (I actually tried it first) but thanks anyway.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial