Setup for multiple 2960G switches

plewk
plewk used Ask the Experts™
on
Folks- I need some help setting up 2 2960G switches for redundancy. I would like to setup the following on each switch:

VLAN1= Data, Servers and workstations
VLAN2=ISCSI SAN

Switches 1 and 2
Ports 1-32 VLAN1
Ports 33-44 VLAN2

Switch 1 Port 48 VLAN1 -> Cisco 3845 WAN Connection
Switch 1 Port 45 VLAN1 -> Switch 2 Port 45 VLAN1
Switch 1 Port 46 VLAN2 -> Switch 2 Port 46 VLAN2

No routing is required (or desired) between VLAN1 and VLAN2

Thank you
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Here is the config for what you are asking.
Also a suggestion would be to combine the two vlans onto a single trunk between the two switches. I did not write the config this way because you have SAN traffic going across vlan 2. This might overload the trunk and cause issues with your vlan 1 traffic. when using trunks with both vlans on them they share the same bandwidth. Another option for this would be to setup an etherchannel which combines multiple interfaces into a single pipe. But that goes a little deeper and requires a little more planning.
 

!S1
int range f0/1 - 32
switchport mode access
switchport access vlan 1 
speed 100
duplex full
int range f0/33 - 44
switchport mode access
switchport access vlan 2
speed 100
duplex full

int f0/45
switchport mode trunk
switchport trunk allowed vlan 1
speed 100
duplex full

int f0/46
switchport mode trunk
switchport trunk allowed vlan 2
speed 100
duplex full

int f0/48
switchport mode trunk
switchport trunk allowed vlan 1
speed 100
duplex full


!S2
int range f0/1 - 32
switchport mode access
switchport access vlan 1 
speed 100
duplex full
int range f0/33 - 44
switchport mode access
switchport access vlan 2
speed 100
duplex full

int f0/45
switchport mode trunk
switchport trunk allowed vlan 1
speed 100
duplex full

int f0/46
switchport mode trunk
switchport trunk allowed vlan 2
speed 100
duplex full

Open in new window

Ha! i overlooked a pretty import aspect with the above config. With the two trunks going between the switches one of them is going to get shutdown by STP. So only one trunk link will be up at any given time. STP does this to avoid loops in your network.
So there are a couple options here.
1)create an etherchannel as mentioned above and combine up to 8 ports into a single pipe.
2) You can setup STP per vlan so each vlan will have its own STP instance. So STP will blcok traffic on one interface for vlan1 and block traffic on the other interface for vlan 2. This takes a little more work and config.
Etherchannel will be the easiest but it has issues and can get messy. STP will take a little more work but will work great. Let me know how you want to go and ill help you out.

Author

Commented:
I'm not a network guy so let me explain what I'm doing and maybe you could suggest the best method.

I am running VMware ESX on 3 hosts. I would like to eliminate my switches as a point of failure by putting half my NICS on one switch and half on the other, of course splitting them by VLANS. VLAN1 is all my standard data and VLAN2 is ISCSI.

Sounds like from your description STP may be the way I want to go.
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

STP is a protocol that runs on all switches. Basically it checks and blocks loops in your network. So with your recommendation you would have multiple connections between two switchs which introduce the possibility of data looping between the two switches which could cause your network to come to a halt. STP resolves this by disabiling one of the two links so a loop is not present. If the first link goes down STP reconizes this and brings the second up.
My biggest concern for you is how much traffic you will be pushing on the ISCSI network. If you have both vlans coming into switch 2 and then going over a single link to switch 1 both vlans will have to share the 100Mbps bandwidth. If the combined traffic is greater than 100Mbps then traffic will start backing up and you will start having issues.
I always prefer to keep SAN/NAS traffic seperate due to the amount of load they place on their links. This is why im recommending either combining multiple links into a trunk which would allow an increase in bandwidth between the two switches. Or we can make changes to STP to allow both links to stay up without having loops.
If you feel your ISCSI traffic is large enough to seperate then we can take you that route or we can combine links between the two switches to 200Mbps (2 ports) 400Mbps (4 links) and so on.
Does this help?
If it's a 2960G you'll need to change the "f" (for fastethernet) on all the interfaces to "gi" (for gigabit).

Author

Commented:
that1guy15,

I definitely would like to segregate my SAN traffic from general network traffic and combiming multiple trucks for the SAN traffic would make sense. STP per VLAN sounds like will keep the traffic separate. A couple of notes: 1- VLAN1 is my management vlan as well as all general network (other than ISCSI) needs to be connected to the WAN. 2. VLAN2 is ISCSI only. Runs in a separate address space and does not need to be routed.  3. As Vito noted this is a gig switch.

Would this work

Switch 1 Port 48 -> Cisco 3845 WAN connection

Switches 1 and 2
Ports 1-32 VLAN1
Ports 33-44 VLAN2
Port 45 VLAN1 to VLAN1 on Switch 2 with VLAN STP
Ports 46-47 combined VLAN2 to VLAN2 on Switch 2 with VLAN STP

Thanks for the help
yes that config will work for getting vlan1 to the internet. Just make sure the end devices use the 3845 ip address as the gateway.
Here is a sample config for your network to seperate the two vlans across the proper trunks. You will just add these lines to the config above. also here is a link that goes over some examples and explains their config.
http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_example09186a00807b0670.shtml#conf 

!S1
spanning-tree vlan 1,2 root primary
!sets the switch to the STP root or master for both vlans



!S2
spanning-tree vlan 1,2 root secondary
!sets the switch to the STP secondary or backup for both vlans

Int gi0/23
spanning-tree vlan 1 port-priority 64
!tells STP to choose this port for vlan1 traffic

int gi0/24
spanning-tree vlan 2 port-priority 64
!tells STP to choose this port for vlan2 traffic

Open in new window

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial