How to make a wordpress site secure and stop "This page contains both secure and nonsecure items" from popping up in IE7

savavoom used Ask the Experts™

I've recently had an SSL certificate installed on my site: 

Now it's fine in every browser apart from IE7 which does my head in!

I get the normal error message:

'This page contains both secure and nonsecure items, do you want to continue. '

On every page.

I've tried changing everything to https instead of http and creating relative file locations but nothing seems to ditch that stupid message.

Is there a way to do this, and specifically in wordpress?

Any help would be much appreciated!

Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
It looks like the problem is that you are accessing unsecure images. For example your logo on the "My Account" page.
Line 132:                  <img class="headerimage" src="" alt="Disco Pixels - Professional Canvas Printing"/>
I use this plugin for this so that it's not necessary to manually change everything to https in your code.

This plugin works very nice, but after activation, if you still see the secure/non-secure warning:
View your source on one of your https pages - check in the header area for other plugin's included scripts still showing http (mostly javascript and css includes.) I normally just add to the plugin for those particular plugins, but I'm not sure how familiar or comfortable you would be with plugin codes.

Here's a problem

<!--[if lt IE 8]>
      <script src="" type="text/javascript"></script>

you are specifically loading a script from a non-secure site when the browser is IE7 or less.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Couple more

<!-- Start Of Script Generated By cforms v11.0 [Oliver Seidel |] -->
<script type="text/javascript" src=""></script>
<!-- End Of Script Generated By cforms -->
<script type="text/javascript" src=""></script>


Still can't get the site to work properly in IE.

I've changed all suggestions to https, I've done a find and replace on every file in the site and replaced http with https.

That plugin didn't seem to make a difference. When you say "but I'm not sure how familiar or comfortable you would be with plugin codes." Do you mean I should go into the plugin itself and adjust some settings in the code?

Any more ideas?

I didn't think it would be this hard!

Thanks everyone for the current suggestions!

Also when I change the googlecode file into https it prompts for a user name and password before the page loads, but still the secure site issue comes up.


Those 4 links I pointed out are still http:// when I view the souce code from


<link rel="stylesheet" href=""

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial