Connecting to UNC with alternative names in host file

monfortir used Ask the Experts™
I have added a different name of the local server in it's hosts file. The servers actual name is web2-test and it is on a domain named Therefore it's FQDN is and it has an ipaddress of

I added an entry in the host file named that also resolves to I had to do this because an application we are testing must use the external name to work but it needs to resolve to the internal address. There is a different external IP address assigned to that client use to connect to.  

When I connect to a share on web2-test or it connects fine. If I try to connect to I keep getting the prompt for a username and password. The name resolves correctly to

Why is this happeneing and how can I get around it?
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
PowerShell Developer
Top Expert 2010

File Share?

Have you already disabled Strict Name Checking? If not, you will need to for 2003 / 2008:

This is an age-old problem with connecting to SMB shares using an Alias.


To resolve this problem in Windows Server 2003, follow these steps:
-Start Registry Editor (Regedt32.exe).
-Locate and click the following key in the registry:
-On the Edit menu, click Add Value, and then add the following registry value:
   Value name: DisableStrictNameChecking
   Data type: REG_DWORD
   Radix: Decimal
   Value: 1
-Quit Registry Editor.
-Restart your computer.

You may also have to set the SPN (Service Principal Name) for the Alias Name.
  setspn -a host/ web2-test

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial