PAGE_FAULT_IN_NONPAGED_AREA (50) Blue Screen in Windows 7 Ultimate 32 bit

DSM_22
DSM_22 used Ask the Experts™
on
Ok so I have 2 users with 2 new Dell Vostro 1720 laptops.  Both are getting 'low physical memory' errors with BSOD after about 8 hours of uptime.  This is the memory dump from one of the laptops (attached and visible).  Taskhost.exe seems to be the culprit, any advice on how to fix this?

PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: fdd48a10, memory referenced.
Arg2: 00000001, value 0 = read operation, 1 = write operation.
Arg3: 81efd3a5, If non-zero, the instruction address which referenced the bad memory
	address.
Arg4: 00000000, (reserved)

Debugging Details:
------------------

Unable to load image \SystemRoot\System32\win32k.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for win32k.sys
*** ERROR: Module load completed but symbols could not be loaded for win32k.sys

Could not read faulting driver name

WRITE_ADDRESS: GetPointerFromAddress: unable to read from 829b9718
Unable to read MiSystemVaType memory at 82999160
 fdd48a10 

FAULTING_IP: 
win32k+cd3a5
81efd3a5 8908            mov     dword ptr [eax],ecx

MM_INTERNAL_CODE:  0

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x50

PROCESS_NAME:  taskhost.exe

CURRENT_IRQL:  0

TRAP_FRAME:  8d94fab8 -- (.trap 0xffffffff8d94fab8)
ErrCode = 00000002
eax=fdd48a10 ebx=ff2174d0 ecx=ff1dd118 edx=00000000 esi=ffbbc958 edi=00000000
eip=81efd3a5 esp=8d94fb2c ebp=8d94fbb4 iopl=0         nv up ei ng nz na po cy
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010283
win32k+0xcd3a5:
81efd3a5 8908            mov     dword ptr [eax],ecx  ds:0023:fdd48a10=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from 828975f8 to 828d68e3

STACK_TEXT:  
8d94faa0 828975f8 00000001 fdd48a10 00000000 nt!MmAccessFault+0x106
8d94faa0 81efd3a5 00000001 fdd48a10 00000000 nt!KiTrap0E+0xdc
WARNING: Stack unwind information not available. Following frames may be wrong.
8d94fbb4 81e9c74e 8574f790 00000001 0705017c win32k+0xcd3a5
8d94fbd0 81e9c795 07050105 00000000 8d94fbfc win32k+0x6c74e
8d94fbe0 81e9c9e6 0705017c 00000000 fe403140 win32k+0x6c795
8d94fbfc 81e9c904 fe403140 00000001 fe36b008 win32k+0x6c9e6
8d94fc18 81ed03a2 fe403140 00000001 00000000 win32k+0x6c904
8d94fc60 81ed0e38 fe403140 8d94fca0 fe40317c win32k+0xa03a2
8d94fcb0 81ecfff0 00000000 00000000 fe4021d8 win32k+0xa0e38
8d94fccc 81ed0bd3 fe401eb8 0002004c 00b0f3cc win32k+0x9fff0
8d94fd18 81eb784d 00000000 00b0f3cc 8d94fd34 win32k+0xa0bd3
8d94fd28 8289442a 0002004c 00b0f584 77b264f4 win32k+0x8784d
8d94fd28 77b264f4 0002004c 00b0f584 77b264f4 nt!KiFastCallEntry+0x12a
00b0f584 00000000 00000000 00000000 00000000 0x77b264f4


STACK_COMMAND:  kb

FOLLOWUP_IP: 
win32k+cd3a5
81efd3a5 8908            mov     dword ptr [eax],ecx

SYMBOL_STACK_INDEX:  2

SYMBOL_NAME:  win32k+cd3a5

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: win32k

IMAGE_NAME:  win32k.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4a9f3cbf

FAILURE_BUCKET_ID:  0x50_win32k+cd3a5

BUCKET_ID:  0x50_win32k+cd3a5

Followup: MachineOwner
---------

Open in new window

012710-16411-01.zip
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2010

Commented:
This is classic win32k.sys error.
Reasons can be many.
Just google for : Windows 7 win32k.sys
Top Expert 2010
Commented:
C&P:
The behavior may occur if the win32k.sys is corrupted. Go to
C:\WINDOWS\System32 and rename the Win32k.sys file to Win32k.old and then
close the window. Now go back to the system32 folder and you will have a
new and non-corrupt Win32k.sys file.

The behavior also may be caused by that the virtual memory of the Windows XP
is corrupted. Disable and then enable the Virtual Memory to see whether it
solved the problem.

To disable Virtual memory:

1. Right click My Computer and choose properties
2. Click the Advanced tab
3. Under Performance click settings.
4. Click the Advanced tab.
5. Under Virtual memory click change
6. Click no paging file
7. Click OK
8. Restart the computer

To enable Virtual memory:

1. Right click My Computer and choose properties
2. Click the Advanced tab
3. Under Performance click settings.
4. Click the Advanced tab.
5. Under Virtual memory click change
6. Click System Managed Size
7. Click OK
8. Restart the computer

Author

Commented:
Nice Thanks for the post senad.  I tried the win32k.sys option and the user is on the machine right now.  If I'm still having issues after this I will try the virtual memory option.

I'll report my findings in a few days after lots of testing.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Un-install the eConceal Firewall  - use Revo if you need to --> http://download.cnet.com/Revo-Uninstaller/3000-2096_4-10687648.html?part=dl-6294459&subj=dl&tag=button
Update NVIDIA video --> http://www.nvidia.com/Download/index5.aspx?lang=en-us
Update NVIDIA nForce drivers - same site
Update your  Broadcom iLine10 PCI Network Adapter - I believe it to be USB.  Sorry, no download link for the Broadcom as of yet.
Regards. . .
jcgriff2
 
 

Author

Commented:
After updating the drivers, doing the win32k.sys fix I haven't seen the error yet.

Thanks for the help!

Commented:
I am having a similar issue but when I go to rename win32k.sys it will not allow me to. It says I need permission from 'TrustedInstaller', prompts me to try again but never actually gives me the option to ok the change of name. Any thoughts? I'm on Win7 64-bit and getting 0x1a and 0x50 blue screens.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial