Visio 2003 Internet Explorer add-on will not open .VSD files

rraudez
rraudez used Ask the Experts™
on
Hey guys,

A co-worker in the office was emailed a .VSD file and needs to be able to view it. I installed the Internet Explorer add-on to view those files in I.E. however, when I attempt to open the file, there is nothing displayed, nor are there any error messages visible. I have gone into the browsers advanced settings and enabled Active content, still no luck. the machine is running Office 2003, on Windows XP - 32bit and the browser is Internet Explorer 7. I tested the file on my personal computer and it opened without error so I know the file isn't corrupt.

I've also tried saving the file to the drive, still get the same thing when trying to open.

Along with the above, I have also tried installing the 2007 Visio add-on. No luck.

Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Did you disable Pop-up blocker on IE?
Scott HelmersVisio Consultant, Trainer, Author, and Developer
Most Valuable Expert 2011

Commented:
Is this where you got the Visio 2007 Viewer? http://office.microsoft.com/en-us/downloads/CD102071301033.aspx

It sounds to me like your colleague has one of two problems: 1) the Visio Viewer isn't registered with Windows to handle VSD files (this should have happened automatically when you installed the Viewer); or 2) the Visio file is corrupt.

You should be able to resolve #1 by using Windows Explorer: right-click on the VSD file, then select Open With/Choose Program... If the Visio Viewer isn't in the list, browse to locate it.

The best way to eliminate #2 is to have someone open the file with Visio to ensure that it wasn't corrupted en route from the sender.

Re the above download page: please note that there are two service packs and a security update that you should apply.


Commented:
@tiepld:
I'm not sure if the pop  up blocker is disabled on that machine or not, however if it were related to that wouldn't IE notify me that there was something being blocked?


@scott:
I have assigned IE to open .VSD files by default as the Visio Viewer is just an add-on for IE, is it not?

I've also forwarded the email to myself and was able to open it without error on Windows 7 64bit. So I know there's nothing wrong with the file.

I did find, after doing even more research, that there was a possible fix which included the following: After installing Visio Viewer 2007 and SP2 for Visio Viewer 2007, install (re-install) Microsoft Update KB973709.

I think I'm going to give that ^ a shot and hope it works, Ill post back if it does/doesn't.

If you guys have any other input, let me know!

Thanks.
Scott HelmersVisio Consultant, Trainer, Author, and Developer
Most Valuable Expert 2011

Commented:
I don't have a machine on which to try it at my current location, but I think you want to assign VSD to the viewer itself and not to IE. It's true that the Viewer runs with IE but it seems to me the file association is with the viewer. I can test this next week if you haven't resolved the problem by Monday.
Scott HelmersVisio Consultant, Trainer, Author, and Developer
Most Valuable Expert 2011

Commented:
I'm glad you found an answer to your problem.

Scott

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial