cannot run successful BERT on cisco router with loopback plug on good T1 port

sniderman42
sniderman42 used Ask the Experts™
on
I'm trying to run BERT on a Cisco on a line that I know is good (so I expect good BERT result).  But even with a T1 loopback plug (shorted pins 1to4, 2to5) directly in the Cisco T1 port, I get 0 syncs (port shows carrier detect).  The equipment at the other end of the line seemed to successfully receive the loopback command and place itself into loopback mode.

I am new to BERT, so I am not confident that I've set everything up properly.  I am confident that I am using the correct port (I have 4 T1s in an MLFR configuration, which works well).  I started by changing encapsulation of the serial interface 0/1:0 to hdlc, and sending remote loopback command from controller 0/1 (I have two dual T1 controllers - VWIC-2MFT-T1).

Here are my results running the test with a loopback plug:

Router7008#bert controller t1 0/1 channel-group 0 pattern qrss interval 1
Router7008#show controller t1 0/1 bert
T1 0/1 is up. (Far End Line Loopback with ESF BOC)
BERT is in progress on channel-group 0. The result of last time is
   DSX1 BERT status        : no sync
   DSX1 BERT pattern     : QRSS
   DSX1 BERT sync count  : 0
   DSX1 BERT interval    : 1 min
   DSX1 BERT time remain : 0 min 48 sec
   DSX1 BERT total errs  : 1415275113
   DSX1 BERT total k bits: 921553
   DSX1 BERT errors (last): 0
   DSX1 BERT k bits (last): 0
Router7008#show controller t1 0/1 bert
T1 0/1 is up. (Far End Line Loopback with ESF BOC)
BERT is in progress on channel-group 0. The result of last time is
   DSX1 BERT status        : no sync
   DSX1 BERT pattern     : QRSS
   DSX1 BERT sync count  : 0
   DSX1 BERT interval    : 1 min
   DSX1 BERT time remain : 0 min 34 sec
   DSX1 BERT total errs  : 557404520
   DSX1 BERT total k bits: 3159612
   DSX1 BERT errors (last): 0
   DSX1 BERT k bits (last): 0
Router7008#show controller t1 0/1 bert
T1 0/1 is up. (Far End Line Loopback with ESF BOC)
BERT is done on channel-group 0. The result of last time is
   DSX1 BERT status        : done
   DSX1 BERT pattern     : QRSS
   DSX1 BERT sync count  : 0
   DSX1 BERT interval    : 1 min
   DSX1 BERT time remain : 0 min 0 sec
   DSX1 BERT total errs  : 4147541425
   DSX1 BERT total k bits: 8293982
   DSX1 BERT errors (last): 0
   DSX1 BERT k bits (last): 0
Router7008#


and here is my running-config:

Current configuration : 3136 bytes
!
! Last configuration change at 16:23:32 PST Thu Jan 28 2010
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec localtime
no service password-encryption
!
hostname Router7008
!
boot-start-marker
boot-end-marker
!
!
clock timezone PST -8
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 10.10.45.1 10.10.45.150
ip dhcp excluded-address 10.10.46.1 10.10.46.150
!
ip dhcp pool T1
   network 10.10.45.0 255.255.255.0
   default-router 10.10.45.1
   dns-server 12.127.17.72 12.127.16.68
!
ip dhcp pool T1_2
   network 10.10.46.0 255.255.255.0
   default-router 10.10.46.1
   dns-server 12.127.17.72 12.127.16.68
!
ip audit po max-events 100
multilink bundle-name both
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 0/0
 framing esf
 fdl both
 clock source internal
 linecode b8zs
 cablelength short 133
 channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/1
 framing esf
 fdl both
 clock source internal
 linecode b8zs
 cablelength short 133
 channel-group 0 timeslots 1-24 speed 64
 loopback remote esf line
!
controller T1 0/2
 framing esf
 fdl both
 clock source internal
 linecode b8zs
 cablelength short 133
 channel-group 0 timeslots 1-24 speed 64
!
controller T1 0/3
 framing esf
 fdl both
 clock source internal
 linecode b8zs
 cablelength short 133
 channel-group 0 timeslots 1-24 speed 64
!
!
!
!
!
interface MFR0
 mtu 9172
 no ip address
 encapsulation frame-relay IETF
 frame-relay multilink output-threshold 512
 frame-relay lmi-type ansi
 frame-relay intf-type dce
!
interface MFR0.16 point-to-point
 ip address 10.10.45.1 255.255.255.0
 no cdp enable
 frame-relay interface-dlci 16
!
interface FastEthernet0/0
 ip address 10.10.30.103 255.255.255.0
 duplex auto
 speed auto
 no cdp enable
!
interface Serial0/0:0
 mtu 9180
 no ip address
 encapsulation frame-relay MFR0
 load-interval 30
 no arp frame-relay
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 shutdown
 duplex auto
 speed auto
 no cdp enable
!
interface Serial0/1:0
 mtu 9180
 no ip address
 load-interval 30
!
interface Serial0/2:0
 mtu 9180
 no ip address
 encapsulation frame-relay MFR0
 load-interval 30
 no arp frame-relay
!
interface Serial0/3:0
 mtu 9180
 no ip address
 encapsulation frame-relay MFR0
 load-interval 30
 no arp frame-relay
!
interface Virtual-Template45
 ip address 10.10.45.10 255.255.255.0
 peer default ip address dhcp-pool T1
 ppp authentication chap pap
 ppp multilink
!
interface Virtual-Template46
 ip address 10.10.46.10 255.255.255.0
 peer default ip address dhcp-pool T1_2
 ppp authentication chap pap
 ppp multilink
!
ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.30.1
ip route 10.1.1.0 255.255.255.0 10.10.45.100
ip route 10.10.30.0 255.255.255.0 FastEthernet0/0
!
!
access-list 100 deny   icmp any any echo
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
ntp clock-period 17179716
ntp server 192.43.244.18
!
end
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
Please ask the provider what timeslots are used...

If 1-24 please ask a loop from ISP node to nodes to find which node causes BERT

Author

Commented:
no provider - I control both ends of the T1; The cisco is configured as the provider, with a T1 loopback plug in the 0/1 T1 port.
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
what type of dce device do you use?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
The only equipment in the test is a Cisco2621XM router with a loopback plug in the T1 (0/1) port; the BERT test is being run from the Cisco.  As far as I understand BERT, this should be enough to run a loopback test successfully (the T1 port being used is a known-good port for T1).
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
interesting, plesae plug loop the remote end and tell us

Author

Commented:
The results listed in the description are from a bert test with loopback in remote end.  Test fails.

Commented:
Hello

If you are testing with a hard loopback plug, you should remove the command loopback remote esf line under your controller T1 0/1 configuration and then start again the bert test.
You do not need to have your controller configure in loopback mode if you are already using a Hard Plug Loopback.

hope it helps

Author

Commented:
Hard loopback plug test still fails with loopback command removed from under controller T1 0/1.

Author

Commented:
I have also tried same thing on a newer router (also with loopback plug) so it doesn't appear to be a hardware problem.
finally found a piece of equipment where bert could be successfully run from.  Three 2600 routers, each with two vwic dual t1 cards were tried.  One of them had a vwic where bert worked on both ports.  So, it seems to be hardware related.  Anyone else ever have a vwic from which bert couldn't be run successfully, even though that card performs just fine when used for T1 access?

Author

Commented:
fwiw - also found that successful bert test followed the card to other routers

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial