WSADMIN Error at Startup

RishiBang
RishiBang used Ask the Experts™
on
Hi,

I have installed the WebSphere Application Server v6.1 (32Bit) on Windows 2008 machine.

As part of doing some scripting work when I tried to start the wsadmin command its failing by throwing security (Acess denied) exceptions (Log attached)

I am using windows services (created by the installer) for starting/stopping the Websphere.

Quick response from anyone from EE is appreciated.

Thanks
Rishi

wsadminError.txt
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Software Engineer
Commented:
What kind of username was used to install WebSphere?

Notice the 1st line of the log file after the "Current Environment" banner,
i.e., just after "************* End Display Current Environment *************"

Failed to open trace log file D:/IBM/WebSphere/AppServer/profiles/AppSrv01/logs/wsadmin.traceout com.ibm.ejs.ras.RasException: Unable to create FileOutputStream over file D:/IBM/WebSphere/AppServer/profiles/AppSrv01/logs/wsadmin.traceout

It looks like the wsadmin tool doesn't have permission to write/create this file.

Author

Commented:
Hi HornorGod,

After installing WebSphere and before starting the WAS,
I have configured the windows service for WAS to run on an userid that is a member of "Administrators" group in windows user registry.

Is there anything else required to prevent this error condition?

Thanks,
Rishi

Top Expert 2004
Commented:
Hi RiShiBang,
I think you starting websphere with a different user from the user that you use to install it.

Try to logout and logon windows with the user you installed it.

Hope this help,
Sompol
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
Hi Sompol,

Thanks for the response

Yes I did that to verify that the user id used for installation is working fine.

Thanks,
Rishi
HonorGodSoftware Engineer

Commented:
> I have configured the windows service for WAS to run on an userid that is a member of "Administrators"

That tells WebSphere to execute in the Administrator group, which is fine.

When you try to execute wsadmin though, how are you logged in?
Hopefully, as a user in the Administrator group.

Author

Commented:
Hi All,

I have resolved this problem by renaming the wsadmin.traceout file(which is target of the access denied error) and restarted the wsadmin.

Thanks for the information provided

Rishi
HonorGodSoftware Engineer

Commented:
Thanks for sharing your solution, and the points.

Good luck & have a great day.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial