User is having problems receiving large pdf files

jp_tech used Ask the Experts™
We have a SBS 2008 server with Exchange 2007, with about 45 mailboxes.  We suscribe to Spam Soap which is MX Logic technology to filter our mail for spam.  One of our customers is trying to send one of our employees an 8mb pdf file, the message gets kicked back and the user gets an undileverable error.  To test I sent an 8mb pdf from an external address and more or less got the same error he did.  I checked the Spam Soap Console and there are no restrictions set for the pdf file type or size and I added the senders domain to the global accept list.   In Exchange I increased the send and receive size for the employees mailbox.  Below is the message I get.  Any ideas if this is an Exchange issue or is it the Spam service?

message cannot be delivered to the following recipients:

  Recipient address: 
  Reason: SMTP transmission failure has occurred
  Diagnostic code: smtp;552 Backend Replied []: 5.3.4 Message size exceeds fixed maximu
  Remote system: dns; (TCP||64502||25)
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
The error shown here is a size limit restriction. Have a look here to make sure you made the proper adjustments

It's probably a size limitation on MXlogic.  Can you send that same PDF withing exchange locally?
from my experience with exchange 2003, there are multiple places to set the actual maximum receiving limit within the exchange organization. i've had a change to use exchange 2007 for a little and its definitely different and just a tad bit more complicated. with that said, check out the below link, i think it will have all the info to point you in the right direction.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

here's an additional link with some very good info and instructions on how to set custom limits as well.


I was able to send the 8mb file internally without any errors.
if you already validated that your spam solution doesn't have a max size limit configured, then take a look at the links to the articles i sent you. intra-organization email limits can and most likely are configured with different limits versus inter-organization email limits.

if anything, use those articles to figure out what those limits are configured to in your setup, you may find you need to adjust it on your receiving connector on the hub transport server.


ok I will look over those links and apply changes.  I sent the same file to an outside user that uses the same filtering service and this is the message I got.

This message was created automatically by mail delivery software.

A message that you have sent could not be delivered to one or more
recipients.  This is a permanent error.  The following address(es) failed:

  <>: 552 Backend Replied []: 5.3.4 Message size exceeds fixed

Included is a copy of the message header:
Received: from unknown [] (HELO
        with SMTP id (envelope-from <>);
        Fri, 29 Jan 2010 07:53:57 -0700 (MST)
Received: from source ([]) (using TLSv1) by ([]) with SMTP
        ID; Fri, 29 Jan 2010 06:53:03 PST
Received: from SERVER01.domain01.local ([fe80::561:9b6b:e65a:6b77]) by
 SERVER01.domain01.local ([fe80::561:9b6b:e65a:6b77%10]) with mapi; Fri, 29
 Jan 2010 09:53:43 -0500
From: Jose Pichardo <>
To: "" <>
Date: Fri, 29 Jan 2010 09:52:34 -0500
Subject: FW: test internal
Thread-Topic: test internal
Thread-Index: AQHKoO7SZW9g9groeU+T2VP5J0g/zpGso4R5
Message-ID: <963283771C370947BC30EF1103C307CE5889A8DFDC@SERVER01.domain01.local>
References: <963283771C370947BC30EF1103C307CE5889A8DFDA@SERVER01.domain01.local>
In-Reply-To: <963283771C370947BC30EF1103C307CE5889A8DFDA@SERVER01.domain01.local>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
acceptlanguage: en-US
Content-Type: multipart/mixed;
MIME-Version: 1.0


Do any of you know if you have to restart the mail services after you change global message limits size?

Have you looked at the settings yet? It looks like that's where it's giving the max size limit error.


I did check the MXlogic settings, I even opened up a service request with them.  They say that everything is ok on their end, all the settings are configured to allow the file type and unlimited size.  The next step is to change the global settings at the hub transport level then test some more.  The mistake I made was changing the users mailbox size, but as I read in the links provided that Global settings override individual mailbox settings.


Thx guys for your help.
We have the same problem with MXLogic with Several different clients and the same response is what we are getting. The actual Tech from MXLogic stated the 552 Backend Replied says that the mail server is denying it. MXlogic just got purchased by MACAFEE and there has been little issues all over because of it. All limits on our Exchange Enterprise are set to no limits or are at 50MB's and also the MXLogic settings are set to Any Size and we are still getting the problem. I might think that a reboot of the server might help.
We're having the same issue (Thank God for Experts Exchange!).  Our Exchange 2007 limits are capped at 50M for sending or receiving, unlimited on the MX Logic side and we're having the same issue.
Hey guys. I am also receiving this NDR and I'm using SpamSoap. Can we safely determine that this is a SpamSoap issue?

Thank you for your help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial