SBS 2008 - Gateway IP Address Lost after re-boot

Siv
Siv used Ask the Experts™
on
Hi,
I have an SBS 2008 box that seems fine on a day to day basis, yet wheneever it is restarted after applying updates it loses internet connectivity.  The reason is that the gateway IP address is missing in the Local Area Networking settings.

Is there a way that this can be fixed or a script I could put in the startup that will put that back?
Siv
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Brian PiercePhotographer
Awarded 2007
Top Expert 2008

Commented:
I had a similar issue, I had a service running which was just identified by ##IdString # and a load of numbers - no service name.

Googeling suggests this may have been installed by one of serveral Adobe Products (god bless them) and it part of the Bonjour service, apparently this is prone to starting before the network services and when it does its know to cause this problem.

Disabling the service has solved the issue in my case

I have seen he same issue, but there can be multiple causes.  I have seen issues with this happening after SP2 was installed, but there was an update from Microsoft the allegedly resolve this issue.  It is possible that if IPv6 is enabled it can cause this issue.  Another cause could be the NIC itself which you may need to update the drivers for.  If that does not apply you can try to update the BIOS, that is most likely what the manufacturer of the Server would have you do anyway.
Siv

Author

Commented:
KCTS,
Thanks for your comment, I have just logged in remotely to the server and I cannot see any services running like the ones you mention, all of them have readable names none with strange ID numbers.
I also looked to see if there were any bonjour or Adobe services and there aren't. The Server has no client software installed like adobe reader (I wouldn't put Adobe on anyway I thing foxiit reader is way better and usues a lot less resources than adobe's bloatware!
Siv
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Brian PiercePhotographer
Awarded 2007
Top Expert 2008

Commented:
I cannot see how a BIOS update would have any effect whatsoever on a NIC and the gateway that is assigned to it, the NIC
Siv

Author

Commented:
msmith1337,
The server is fully patched and all drivers are the latest from Dell. I think it may ghave started after SP2 (not 100% sure as it only happens when you re-boot and I try to keep that to a minimum as we have lots of remote users who are logged in from all over the World in different time zones).

Do you have a link to the fix from MS or a keyword to look up to search for it as I can't spot it?

Siv
I am not sure what specific update it was, just one of the updates after SP2 was released.  I found this post with a few users having the same issue and this was the fix

1. Open the registry with regedit.exe
2. Go to the path: HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/Interfaces/
3. Here you'll need to select the CLSID of your networkadapter where you change the settings. You'll probably recognize it by looking at the value IPAddress that will have the IP of this adapter.
4. Open the value "DefaultGateway" by doubleclicking it. You will see a list of all the gateways that disappeared! (maybe in your case it will be only one, in my case there were due to lots of testing several addresses) Very likely, the first line will be empty. I'm not sure, how this little flaw can make such a big problem. However, if you manually remove this first empty line, click OK and reboot your system everything should be working fine again.
Siv

Author

Commented:
msmith1337
Thanks for that just logged in and as you said there was a blank row before and after the correct gateway IP address and in the key when I viewed it before making the change there was nothing listed in the data colum for "DefaultGateway" after removing the blank lines there now is the correct IP Address.

I can't reboot at the moment but this definitely looks to be the fix for this, so thanks for that.

FaultyGatewayKey.jpg
The reset command is available in the IP context of the NetShell utility. Follow these steps to use the reset command to reset TCP/IP manually:
To open a command prompt, click Start and then click Run. Copy and paste (or type) the following command in the Open box and then press ENTER:
cmd
At the command prompt, copy and paste (or type) the following command and then press ENTER:
netsh int ip reset c:\resetlog.txt
Note If you do not want to specify a directory path for the log file, use the following command:
netsh int ip reset resetlog.txt
Reboot the computer.

Here's the official solution - http://support.microsoft.com/kb/299357 
Siv

Author

Commented:
Ashimmons,
I followed the link to the KB Article and looked at the O/Ss that this fix applied to and noticed that Small Business Server 2008 was noticeable by its absence. That said, the underlying operating system of SBS 2008 is there so I guess it's OK to run it.

What IP Address will this set the server back to, as the IP address of an SBS box is pretty critical and I wouldn't want it setting to some random IP? 192.168.0.1 or whatever as this would mess everything up I would imagine on an SBS box.

Thanks fo rthe comment though, as I discovered that after the first remote restart the fix originally outlined worked but the second time it didn't.  I subsequemtly tried a startup script that reset the IP Address the subnet mask and teh gateway, but this seemed to cause loads of other errors that were worse than just getting one of the staff at the site to manually set it back when the gateway was lost.

Cheers,
Siv

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial