PyQt (Python-qt) installation on Redhat

v_shalchian
v_shalchian used Ask the Experts™
on
Hi,
I'm asked to install PyQt onRedhat EL 5.
This is what I'm talking about :
http://www.riverbankcomputing.com/software/pyqt/intro

I downloaded the source code and tried many times to compile just like the documentation says and I face compile errors.
I searched the compile errors in internet.There is a lot of pages related to these errors but there is not any answer to them.

I searched the internet for RPM's and downloaded but they have hundred of hundred of dependencies which some of the dependencies does not exist in the RPM sites.
I'm sure there is not a YUM repository which contains it (I have been searching for days).

I tried Ubuntu and the result was worse.

I was wondering if anyone which has used it before could help me.



Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
Problem with PyQt and other fancy python stuff that it requires newer python version, for example 2.6
Standart RHEL5 has python 2.4.3, so first you have to install newer python in a place, where it'll not
interfere with system python - for example, in /usr/local
After that you have to pay attention installing python packages - they should go to /usr/local/lib/python2.6 and not to /usr/lib/python2.4

Author

Commented:
hurray !

I finally succeeded in compiling and installing PyQt.

I compiled Python 2.6 from source.
Then i compiled and installed  "sip-4.10" and "qt-everywhere-opensource-src-4.6.1" (The latter took me hours to "make")
After that I configured PyQt with new parameters and there was no error.
Finally there  was "make" and "make install".

Tthanks.

Author

Commented:
It helped me to find the solution.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial