Outlook 2007 prompts for password on member servers everytime. Seems DNS related

akbulll
akbulll used Ask the Experts™
on
I have several servers that run TS desktops for users via XenApp. Recently all users began being prompted for an Outlook and SharePoint login each time they logged into their Windows session.

these are W2K3 servers running Outlook 2007, connecting to an Exchange 2007 server, and all are on the domain.

If you choose to save the password, it will not save, but the domain\username stays.

If you do not ebter a password, you are connected to Outlook anyway. It is already Online.

Definitely seems DNS related but I'm not sure where else to look. No DNS or Kerberos errors on the DCs that are related that I can tell.

Thanks!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Rick FeeMessaging Engineer - Disaster Recovery Engineer

Commented:
For Outlook if you open the email accounts --> More settings -->  Click the security tab -->  Under User identification is Always prompt for username and password unchecked?

Author

Commented:
Yes this is unchecked.

Thanks.
Awarded 2009
Top Expert 2010

Commented:
There was an update recently that seemed to cause this problem.

Can you check my guide here: http://www.experts-exchange.com/articles/Software/Server_Software/Email_Servers/Exchange/Outlook-continually-prompting-for-username-and-password.html

specifically the Kerberos authentication part
Commented:
This was resolved after changing the Common Name of the SAN/UCC cert to match the proxy server name.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial