LDAP Enabled PHP

gglollc
gglollc used Ask the Experts™
on
I need to have php enabled with ldap so I can use a WordPress Plugin to authenticate to Active Directory. I have read that php has to be compiled with ldap support. But I have also found php-ldap packages that are supposed to add ldap support to php. So do I really need to compile php, or can I install a php package and then install one of the php-ldap packages like php-ldap-5.2.5-7.fc9.i386.rpm?
I ask becasue I don't know much about compiling php.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
find the line
;extension=php_ldap.dll
in php.ini. Is it commented with ";" on the line beginning ? if so, uncomment it by deleting ";" run phpinfo(); to see if it is eventually enabled, maybe you won't have to recompile it

Author

Commented:
So I assume that if it loaded the extension it's good?

additional .ini files parsed       /etc/php5/apache2/conf.d/gd.ini, /etc/php5/apache2/conf.d/ldap.ini, /etc/php5/apache2/conf.d/mcrypt.ini, /etc/php5/apache2/conf.d/mysql.ini, /etc/php5/apache2/conf.d/mysqli.ini, /etc/php5/apache2/conf.d/pdo.ini, /etc/php5/apache2/conf.d/pdo_mysql.ini

btw PHP at some point started loading extensions from the conf.d directory
did this work ?

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial