Nessus Client Connection Refuses

starcontroller used Ask the Experts™
I have 2 machines:  One with Ubuntu Linux Server and the other with the more common Ubuntu Linux.  I have installed Nessus server and the client with packages from

I have confirmed that the server has started:

Every time I connect, I get the message "It was not possible to connect to the remote host - make sure the host IP and port are correct and that the Nessus Server is running".

Does anyone have any ideas for resolving this?  Thanks.
root@flagship:~# /etc/init.d/nessusd restart
$Shutting down Nessus : .
$Starting Nessus : .

# Port to listen to (old NTP protocol). Used for pre 4.2 NessusClient connections :
listen_port = 1241

# Port for the Nessus Web Server to listen to (new XMLRPC protocol) :
xmlrpc_listen_port = 8834

Open in new window

Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Have you checked that the client machine can see the server's open ports? It might be a firewall in the way?
Try an nmap scan from the client machine (apt-get install nmap):

nmap -p1241,8834 -PN -n -sV <nessus_server_IP_address>



I have attached the results of the nmap scan.
Starting Nmap 5.00 ( ) at 2010-01-30 08:57 EST
Interesting ports on
1241/tcp closed nessus
8834/tcp open   ssl/tcpwrapped

Service detection performed. Please report any incorrect results at .
Nmap done: 1 IP address (1 host up) scanned in 23.76 seconds

Open in new window

Given the scan result, which shows that nessusd is not listening on 1241 and probably is running on 8834 (although nmap wasn't able to tell for sure that it is nessusd) I would say that your problem might be the same as discussed in this thread:

It seems that users of the homefeed must use 'the web interface' - does the aforementioned thread make any sense to you?
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

I've just installed nessusd on a windows machine and the server won't even start until I've registered it and got an activation code.  Have you done that?
Absolutely, and I am using the HomeFeed.  I looked at the link you provided and the HomeFeed does not use a client; no client is required at all.  I can access the server through any web browser over a HTTPS connection.  Although, I had to make one change to my /opt/nessus/etc/nessus/nessusd.conf by changing to my server IP.
# IPv4 address to listen for incoming connections :
listen_address =

Open in new window

Sweet.  I wondered why I didn't have the option to install a client on windows.  Haven't used nessus since they changed all the licensing and if I was going to use something like it, I'd use OpenVAS instead.
So, are you up and running then?


I have heard of OpenVAS, but I never had the chance to try it.  In any case, I am up and running.

Good show.  Thank you for the points.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial