Exchange 2007 owa broke after installing CA certificate

dosdet2
dosdet2 used Ask the Experts™
on
System: Windows 2003 x64, Exchange 2007

We had a crash and rebuilt the exchange server from bare metal - only restored the mailboxes.  Everything has been working OK on the self generated certificate (except for the warnings) and today we re-keyed the CA certificate and installed it.  That broke OWA.  I have enabled the certificate which shows up correctly in IIS and Exchange shell.  I have restarted all exchange services and IIS.  Removed and re-created the virtual folders and it is still Broken.
Terminal services still works as do local Outlook clients.  

When trying to access OWA from a browser we get the following error:
Data Transfer Interrupted.  The connection to mail.domain.com was interrupted while page was loading.  
This error is displayed instantly when the URL is sent.  I am about fried on this.
Any Ideas???





Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Shivkumar SharmaOperations Delivery Manager

Commented:
Firstly type the below in the exchange command shell (run as administrator)

Get-exchangecertificate
( Copy the thumbprints of exch certificate)

Then to enable the particular certificate for all the services type the below command

enable-exchangecertificate -thumbprint (copied thumbprint of the certificate -services SMTP,POP,IMAP,IIS

Author

Commented:
I did this and it does show IP.WS under services / get-exchangecertificate.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Shivkumar SharmaOperations Delivery Manager

Commented:
If you are accessing OWA through Mail.companyname.com then enable that certificate for the services
Firstly copy the thumbprint of that certificate and then run the below command from exchange management shell

enable-exchangecertificate -thumbprint (copied thumbprint of the certificate -services SMTP,POP,IMAP,IIS

Then restart SMTP and Ms exchange transport services.

Please let us know for any queries

1. Verify if the certificate that you enabled on the IIS is a valid certificate or not. You can do this by going to the Certificates Console in MMC and under the 'Personal' store, you should be able to locate the certificate installed.
Right click and Open it. At the very bottom of the certificate, you should get a message "You have a private key that corresponds to this certificate.". If you do not get this message, then get the certificate re-keyed from the 3rd party certificate authority and download and re-enable it on IIS.

2. Try OWA without SSL. Remove the SSL from the Default Web Site and OWA virtual directory and try if you are able to browse OWA on HTTP connection.

Let us know how it goes.

Author

Commented:
I determined that something was wrong the cert just before I got your answer, but nevertheless, it was the right answer.  I am back to the self generated cert for now and when I get it fixed, I'll try it again.  Should be fine now.  Thanks.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial