Removing SSL Certificates on Exchange 2007

SM17CH used Ask the Experts™
Hi Guys,

I am having an issue with outlook over http on exchange 2007 on a sbs 2008 box.

I had a single ssl cert from godaddy installed and was having issues using outlook anywhere (outlook over http) it would work most of the time but users would be disconnected for no obvious reason.

I was told that I needed a SAN certificate which would validate multiple domains and I attempted to install this over the top of the original certificate but I must have stuffed up because after this outlook over http would not work. When trying to connect I get the error

this name could not be resolved the connection to microsoft exchange is unavaliable, outlook must be online or connected to complete this action.

when accessing the OWA I dont get a certificate error and it says it is using a godaddy cert.

does anyone know why this would be happening or how I can remove the current certificates and start from scratch?

I want to either put the old single one back on or try putting the SAN certificate back on.

any help would be great


Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Shivkumar SharmaOperations Delivery Manager
I would personally not recommend removing SSL certificates from exchange 2007 because then it makes it unsecure as the username/password goes in plain text.

In exchange command shell type the below


Copy the thumbprints.

To enable an certificate for all the sevices, type the below command
enable-exchangecertificate -thumbprint (copied thumbprint) -services SMTP,IMAP,POP,IIS


hmm I gave that a go.

I had 2 addresses (one must be the original cert and the other is part of the SAN Cert)  

I tried to enable the second on all the services and it overwrote the other SMTP cert.
once I had done this the OWA became unaccessible and returned a certificate error and a
404 - File or directory not found. The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.
i went back into the exchange shell and enabled the original certificate and overwrote the other again and I am still getting a 404 when I try to access the web page.
: (
any ideas on getting this working again? or just a way of starting from scratch?

Lead Technical Consultant
If you want to remove a Exchange certificate you can
remove-exchangecertificate –thumbprint xxxxxxxxxx.
But  i would suggest you read  this blog first.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!


Thanks I'll check it out.
btw in the process I have lost my entire OWA folder in IIS.
I'm getting a 404 error and the c:\inetpub\wwwroot\owa folder is missing
all I did was change the cert information.
Satya PathakLead Technical Consultant

Issue these commands from the Exchange 2007 Management Shell.

remove-owavirtualdirectory -Identity "owa (Default Web Site)"     (Note the website name is case sensitive)

New-owavirtualdirectory –Name “owa” –website “Default Web Site”

More Info!687C72A5909E4230!211.entry
The OWA folder is not present under "c:\inetpub\wwwroot\owa"

Rather you will find it in the "Client Access" folder in the installation path of Exchange.

Also as Satya told, you can easily create the OWA vDir by running the cmdlet.


Thanks for the help guys guys, all sorted.
looks like outlook anywhere is going smoothly as well.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial