New W2000 guest (my first) no connection to network IP 0.0.0.0

mko0
mko0 used Ask the Experts™
on
I have just setup my first guest. However It has no connection to the net. Shows IP 0.0.0.0
Its setup to use DHCP.
Ipconfig /renew fail.

The host server are reachable on the net.

I would like the guest to get a IP from my router DHCP server.
(Like the host does)

What am I missing and how do I get it to work?

net.gif
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
nappy_dThere are a 1000 ways to skin the technology cat.
Commented:
Did you install the vmware tools?

Also, please bive the vmkernel management port and the vswitch their own network cards

Author

Commented:
Yes vmware tools is on the guest.

How do I do that?
Top Expert 2009
Commented:
If you assigned static ip address to the guest OS, are you able to ping your router?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

nappy_dThere are a 1000 ways to skin the technology cat.

Commented:
IS the network card shown as connected on the guest OS or disconnected?

Author

Commented:
It is shown as connected.

Author

Commented:
Not able to ping gateway with static IP.
nappy_dThere are a 1000 ways to skin the technology cat.

Commented:
  • Delete the Network card from the GUEST OS
  • Shutdown the guest.  
  • Edit the Guest Settings
  • Remove the NIC
  • Start the Guest
  • Shutdown the Guest
  • Edit the Guest Preferences
  • Add the NIC
  • Start the guest
Try now...

Author

Commented:
Did not help.
Net2.gif

Author

Commented:
How can I see if it is bridged or NAT? (ESXi)

Here:
http://communities.vmware.com/message/1129225;jsessionid=EAE509FB36E023B64D11A032E338E31C
They write .vmx should say:
ethernet0.networkName = "NAT"
Or
ethernet0.networkName = "Bridged"

Mine is:
ethernet0.networkName = "VM network"

I tried to change mine to Bridged how ever now it shows "network cabel unplugged".


nappy_dThere are a 1000 ways to skin the technology cat.

Commented:
Based on your first screenshot, you are in bridging your vmkernel and vswitch interfaces.


Author

Commented:
Net setting now shows bridged, but it is not in the option list. Only "VM network".
Could this be the problem - how do i then add bridged?
net3.gif
nappy_dThere are a 1000 ways to skin the technology cat.

Commented:
The term bridging only exists with VMWare server and now ESX or ESXi.

From your screenshot, simply select vm network and this will associate your guest with the vswitch.

Author

Commented:
Yes it does - but I still only get IP 0.0.0.0 and no connection to the network.
Top Expert 2009

Commented:
Recreate the VM using existing vmdk and ensure its network adapter is bind to network label "VM Network" and also ensure the device status is "Connected"
Commented:
Problem solved!

I tried to reinstall a new guest win2000. Here net works fine. So it must be something installed on the converted server that blocks the VMware net. DHCP service was disabled!. I retried static IP and now Im able to ping the gateway 192.168.1.1 and other computers on the internet. (I must have done something wrong first time I tried this). Also the DNS servers was blocked by a software firewall on this guest.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial