Can't type or use keyboard in Windows 7 after just being in Linux Mint 8

Morty007
Morty007 used Ask the Experts™
on
I have windows 7 home premium dual booting with Linux Mint 8, on a Dell XPS M1530.

When I shut down linux mint and go back into windows I have the following problem.

Upon the windows 7 desktop appearing, I am able to type or use the keyboard as usual-until I touch the touchpad on my laptop. After I touch the touchpad, (even for just the slightest second!)  I am unable to type anything. For example, if I launch the start menu and then try to type to find a file nothing will happen. The only way for me to get by this is to reboot the computer again. So essentially I have to reboot twice in order to get a working keyboard with Windows after being in linux. This problem does not happen if I stay in Windows and reboot windows repeatedly. (I tested it by reinstalling windows and having it as the only OS for about a week.)


I tried the following workarounds: using the Dell support software to disable the touchpad when a mouse is present.

I tried reinstalling the touchpad driver.

Nothing has worked. Alps electric is the touchpad manufacturer.

I asked this question on the ubuntu forums and got back the answer that windows doesn't like the other OS on there and upon reboot gets confused or sees things are in a different state.

Another problem which I think is related is after being in Linux aero is disabled and the graphics are not there.

Very annoying problem and I doubt there is a fix for it, but please help if you can.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Well this is a laptop-does that mean its a usb keyboard? Also I appreciate your explanation but am not sure where to start.

Author

Commented:
I really prefer to try something else than set up a virtual pc.

Author

Commented:
Just to clarify-I don't understand how altering text files in Linux will somehow make windows behave properly. As for the virtual PC part, that seems to just be skirting around the issue.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Alan HendersonRetired marine engineer

Commented:
@ Morty007:

The first two posts are directly copied from other websites and are mostly totally irrelevant to your problem.

There is no connection between your Windows and Linux installations, except that it's easy to access your Windows partition from Linux and accidentally or maliciously delete files.

Try attaching a USB mouse to your laptop and see if it works then we can try some repairs. Start with this:
Try System File Checker which repairs or replaces corrupt or missing Windows files:
 
   1. Click Start >> All Programs >> Accessories.
   2. Right click Command Prompt.
   3. Select "Run as Administrator".  
   4. At the command prompt type sfc /scannow (don’t miss the space before the /)
   5. Click OK.

 
Alan HendersonRetired marine engineer

Commented:
1.  Do you have a Dell Windows 7 DVD as opposed to a restoration disc?
This affects what repair options you havew available.

2.  Do you have 32 or 64-bit Windows?
This may be relevant for driver choice.
Does the problem go away when you actually shutdown the computer instead of rebooting?

In Mint, Shutdown, power on, boot to windows, keyboard working?

If so it may be the way that Mint / Ubuntu is putting the devices to sleep hence it failing across reboots.
I would actually ask one of you linux guru's if there is an option which can be set in it's configuration which would drop all the way back to the Dell Bios?
The poster has noted that powering off does fix it and that the problem only occurs when rebooting to Windows from Linux.  Hopefully, reinvoking the Bios would reinitialize the laptop's hardware which is definitely being left in a weird state by Linux.
Alan HendersonRetired marine engineer

Commented:
"one of you linux guru's"
Not guilty.

Sadly.

:)
Duncan RoeSoftware Developer

Commented:
Bit of a wild guess, but are you running framebuffer console? I would try turning it off if you are (console is higher-res than 80x55). Also, try not to shut down from X but go to a console first (Ctl-Alt-F1 or Ctl-Alt-F6 usually)
Duncan RoeSoftware Developer

Commented:
Oops - framebuffer console is higher res than 80x25, not 80x55. If you have the old DOS-style characters, you don't have framebuffer otherwise you probably do.

Author

Commented:
Thanks for all the responses, and thanks to the moderator for getting me attention.

I've been using a usb mouse in my laptop. I do have a windows 7 disc, and it's the "upgrade" disc. This is also a brand spanking new fresh windows 7 installation, so we could try the file checker but I'm sure it will probably be ok.


Just to repeat, the problem only happens when going from Linux Mint to Windows. As soon as I'm in windows I can type........until I touch the touchpad, even for a split second.
OK, two possible thoughts on the Windows side.....
First is that numeous mouse/keyboard issue get fixed by removing the /fastdetect in BOOT.INI.  I don't have a 7 box hooked up at the moment; but, that's worth a try.
The other is why not just disable the trackpad in the device manager?

Author

Commented:
DavisMcCarn- I've tried to uninstall the driver, but windows just finds it again on reboot. Also if you read the main post, I have had the trackpad disabled in the dell trackpad software when a mouse is present.
Don't uninstall it, disable it (Right-click, then choose disable)

Author

Commented:
Ok, just right clicked it and there is no option to disable it. Just rollback driver, details, etc. I'll try your other suggestion though.
Alan HendersonRetired marine engineer

Commented:
Have you tried using Windows System Restore to a time before this happened? It shouldn't affect your grub boot setup.

Author

Commented:
There is a disable for the HID compliant mouse, so what I did was unplug my usb mouse and then when the device manager refreshed itself and disabled the only remaining hid mouse there, but the cursor/touchpad still worked. I'll reboot into linux and then back and see if it did anything.

Also I do not see a /fastdetect in BOOT.INI.  in msconfig.

Author

Commented:
@Davis- Still not working. And I don't know if this is related but when I come into windows from linux most of the time the aero effects are turned off as well. Linux just leaves it in a weird state. I guess.


@Vallis-It's a brand new installation of windows 7, and it happend from the very first time that LInux was on there.


Anything else we can try guys?

Author

Commented:
I just ran sfc /scannow and it said windows did not find any integrity violations. Should I delete the ALPS registry key maybe?
Well, all I can say is YUCK!
I dragged out my Win7 box and there is no /fastdetect (or anything like it) and you cannot disable a PS/2 mouse in the device manage, the option is grayed out.
You can, ironically, disable the USB mouse; but, that sure doesn't help, huh?
You should be able to disable the trackpad in the BIOS (Hit F2 while the Dell screen is up)
I did several Google searches  which disclosed similar problems with ubuntu 9, especially if you have an NVidia graphics chip and there actually seems to be no fix yet except the cold boot unless, as I first asked, there is some way to have linux go all the way back to the BIOS on a reboot.

Author

Commented:
Yeah it's a doozy alright. I went into the bios and looked at each option, but I didn't see anything. I do have a nvidia chip by the way.

Hope we can find an answer. Other dual booters with nvidia must be having the same problem. (BTW, aero is turned off sometimes when I reboot from linux. And when the aero is disabled the keyboard won't work)
The core issue is that the linux is leaving the hardware in an odd state and then Windoze isn't bright enough to reinitialize it on boot.  If we could get linux to flat out jump to the BIOS entry point during a reboot, there is a damned fine chance the BIOS would set things straight.
 
Alan HendersonRetired marine engineer

Commented:
Grasping at straws: try resetting BIOS to the defaults.
Duncan RoeSoftware Developer

Commented:
Did you try changing to a VT (console that looks a bit like DOS) before shutting down Linux?

Author

Commented:
@ Vallis- I'm not sure how to reset to defaults, and the only thing that changed was the boot order. (DVD drive first)

@Duncan- I'm not sure how to do that.
Duncan RoeSoftware Developer

Commented:
Try typing Ctrl-Alt-F6 (hold down the control, Alt and function key 6 keys simultaneously). Expect to see a black & white low-resolution screen containing something like below (except there will be your system name instead of dimstar). Log in as root and issue the "halt" command. If mint doesn't let you log in as root, log in as yourself and issue "sudo halt".
If Ctrl-Alt-F6 doesn't give you a login prompt, try Ctrl-Alt-F1, Ctrl-Alt-F2 etc.
Welcome to Linux 2.6.29.2-2-smp (tty2)

dimstar login:

Open in new window

Duncan RoeSoftware Developer

Commented:
Example of root login on console below. I entered a password bu it doesn't show
dimstar login: root
Password:
Linux 2.6.29.2-2-smp.
Last login: Thu Feb  4 07:44:22 +1100 2010 on tty3.
You have new mail.

dimstar@01:02:58~#

Open in new window

Author

Commented:
Duncan-I'm going to try your suggestion shortly. I am unable to print at the moment, so I'm going to get a HP printer which I know is compatible with linux. (Won't print in Windows either, old printer.)

I'm not sure what to do after the halt command, btw.
Duncan RoeSoftware Developer

Commented:
The halt command will power off the system (or leave it in a state where you have to power it off). Alternatively you can try the "reboot" command which should get you back to your dual boot screen. That will be a real test of whether the keyboard is OK

Author

Commented:
Duncan- Ok I did the halt command and it totally shut off the system. I pressed the on button and when grub appeared I went into windows. Unfortunately the same thing with the keyboard, along with aero being turned off.
Duncan RoeSoftware Developer

Commented:
That's really weird. What do you mean by "aero" by the way?
If you remove power cord and battery, so it *really* powers off, does it come good again?

Author

Commented:
Aero=the effects in Windows 7 with transparency and such. I haven't even tried to remove the battery on the laptop, just had no reason too. All I know is that my desktop at home with the nvidia card does not suffer like this one. They both have linux mint 8 on them.

Author

Commented:
Oh no, are we at the end of the line here? Nobody has a suggestion?
Duncan RoeSoftware Developer

Commented:
Remove the battery - that's a suggestion. That will absolutely reset everything. Another possibility is faulty hardware on your laptop.
Way back at the beginning, your stated problem was that, when you rebooted to Windows from Linux, the trackpad, mouse, and aero, were wacky; but, if you truly shut down or rebooted Windows to Windows, eveything was fine.
Occam's razor says that the problem is Linux leaving the hardware in an unfriendly state and searching revealed to me it is not just with your flavor of Linux.
There is only one hope (period).  If there is a way to have quitting Linux explicitely reinvoke the BIOS, it may reinitialize the hardware and solve the problem.
If that is not possible, you will have to shut down Linux so the system turns off and then reboot to Windows when you want to switch.
 

Author

Commented:
I'll try the battery trick. I posted in the linux mint forums and someone replied :

"It is something in the "super IO" that gets reset in some strange way - there's a lot of what I'd call semi firmware in computers these days - most famous perhaps the one you use fwcutter for (Broadcom)"

The thread is here http://forums.linuxmint.com/viewtopic.php?f=49&t=40976

Author

Commented:
I just spent a while in linux, then did a complete shut down and removed the battery for a few minutes. Came back to Windows 7 and....same thing. No typing if I touch that touchpad, and the video driver was in low graphics mode.


Guess it's just unsolvable.
If you reboot Windows from Windows, does it still work?
And, as a complete aside, the battery trick is to force the system to lose anything it may still have in ram and/or ultra low power states (i.e. hibernation).  In many cases, there is an extra step in trying to turn it back on with no ac or battery which forces the system to lose all power.
It does not; however, affect anything kept in the BIOS or in non-volatile chip registers.

Author

Commented:
Everything is still fine from Windows to Windows.
Duncan RoeSoftware Developer

Commented:
Do you mean everything has come fine at some point since your last Linux session? It's OK now, right?
OK, Morty,
The root cause of this is that one (or more) settings in the core chipset's registers is being changed by Linux AND the BIOS does not reset it to it's proper state for Windows.  All of the timings for memory, video, I/O, and on-and-on, ad nauseum, are set in several hundred registers within the systemboard's chipset which is why you can upgrade your processor or use faster ram without having to use the old school method of changing jumpers or dip switches.
You can research this yourself if you search for chipset tweaking tools.
I would check to see if there is an upgrade for the BIOS as issues like this can cause Windows to blow its cookies if the owner buys some widget that causes a similar problem in Windows.
Failing that, there are chipset and video utilities that let (mostly gamers) push their system's to the edge of falling over; but, have the benefit of setting those registers while Windows is booting up.
Short of those two options, the problem is unsolvable.......

Author

Commented:
Sorry for the late reply. Yes I know now it's unsolvable. Although for the record I spent the past day in linux and I rebooted fine into Windows with everything working ok. There is no bios upgrade, I did do one about a year ago. As for the chipset tweaking tools, it looks a little above my head at the moment.

I appreciate everyone's help. Hopefully my next computer won't do this.

Author

Commented:
This was one of the few unsolvable computer questions.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial