Cannot send or receive internet email in Exchange 2003

c_may
c_may used Ask the Experts™
on
I'm trying to configure Exchange 2003 for the first time.

I have configured my DNS to add an MX record pointing to this mail server's IP.

Through System manager I have completed the internet mail wizard.  I have set up 1 user in active directory and on a workstation with Outlook 2007 have logged in successfully to this account.  I tried sending an email to a external gmail.com address as well as sent a test email from my gmail account to this new exchange email address.  Neither have worked.  I'm assuming I've missed a set of the set up process?  
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Neale WilliamsService Delivery Manager

Commented:
Have you allowed the ports through your firewall? If you are using POP3 you need to allow port 110 to come in. Also have you configured the SMTP connector?

Commented:
First, see your meesage queue on Exchange, there you will see error message for your message to gmail. Put it here, please.

Author

Commented:
I'm using SMTP, i've forwarded port 25.

I haven't configured a "SMTP connector" and I'm not familiar on how to do this.  Do you have a link you'd recommend on how to do that?  I'll google it in the meantime.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Neale WilliamsService Delivery Manager

Commented:
http://www.msexchange.org/tutorials/Configuring-SMTP-Connector.html

In that case have you opened port 25 on the firewall?
Neale WilliamsService Delivery Manager

Commented:
Sorry, Ignore the port.

Author

Commented:
When I click on the gmail message in the queue, it says:The remote server did not respond to a connection attempt.

The state is in "retry" , so I assume its going to try a few more times before it gives a full error message.

Author

Commented:
It looks like an smtp connector was already set up when i ran the internet mail wizard.

Commented:
Try on your exchange server tell in cmd "telnet gmail-smtp-in.l.google.com 25" and put here the results.

Author

Commented:
C:\Documents and Settings\Administrator>telnet gmail-smtp-in.l.google.com 25
Connecting To gmail-smtp-in.l.google.com...Could not open connection to the host
, on port 25: Connect failed

Commented:
try in cmd nslookup gmail.com
Awarded 2009
Top Expert 2010

Commented:
Here's what you need to do:

1) goto http://whatsmyip.org from your exchange server and confirm your external IP address
2) setup an A record for mail.yourdomain.com (for example) to point to the IP address
3) configure the MX record to point to your A record
4) ensure that Port 25 is forwarded from your router/firewall to your exchange servers INTERNAL IP address

the DNS changes can take upto 48 hours to go through.
Then from outside your network run telnet mail.domainname.com 25 do you get a connection?
Awarded 2009
Top Expert 2010

Commented:
Why are we trying to connect to gmail's SMTP server?

Author

Commented:
K.   C:\Documents and Settings\Administrator>nslookup gmail.com
*** Can't find server name for address 192.168.0.1: Non-existent domain
Server:  UnKnown
Address:  192.168.0.1

Non-authoritative answer:
Name:    gmail.com.may-server.cmaynet.net
Address:  72.215.225.9
Awarded 2009
Top Expert 2010
Commented:
What ISP do you use? Do they block port 25?

Author

Commented:
@demazter

1) goto http://whatsmyip.org from your exchange server and confirm your external IP address
Did this and it is the proper address ive been using

2) setup an A record for mail.yourdomain.com (for example) to point to the IP address
Ive created this new A record mail.mydomain.com

3) configure the MX record to point to your A record
I pointed the MX record to mail.mydomain.com
(before doing this i just had my MX record pointing to the external IP address of my server, (the one we got in step 1)
4) ensure that Port 25 is forwarded from your router/firewall to your exchange servers INTERNAL IP address
port 25 is confirmed as being forwarded to my exchange servers internal ip addy

Guess I just have some waiting time going on for now

Author

Commented:
WOW, yea i bet that could definetly be it.   I use cox communications,  and  I'm on a personal account, I bet they are blocking port 25, i do know I can't host web pages on port 80 for this reason.
Awarded 2009
Top Expert 2010
Commented:
MX records should always be configured to use an A record this A record should also be the name used for your rDNS record (contact your ISP to have them setup an rDNS record for your IP address)

can you telnet from outside your domain to the IP address from step 1 using port 25?

Have you configured exchange to deliver mail via DNS or smarthost?
Awarded 2009
Top Expert 2010
Commented:
Hm, unlikely they will have port 25 open then!
Contact them to confirm.
Awarded 2009
Top Expert 2010
Commented:

Author

Commented:
I tried telnetting from outside to my IP (from step1) using port 25 and it said could not open connection to host on port 25

Author

Commented:
Yea they blow.   I guess I'm going to have to buy a damned over priced Business account and its slowww speeds.   Goodbye 20mbps  

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial