Turn off Windows 7 (and W2K8 R2) printer grouping behaviour

Staudte used Ask the Experts™
Hi Experts,

I am frequently creating several printers all pointing to the same device, so that each can have individual print settings, e.g. duplex, paper source or format, etc. Printers are then named, for example, "HP Laserjet Duplex" and "HP Laserjet Simplex" and "HP Laserjet Envelopes". So far, so good.

Windows 7 is now grouping these instances of the same printer in the printers control panel, which makes is clumsy do delete print jobs. Even a simple task like seeing the documents in the queue now takes a couple of mouse clicks and navigating through pull-down-menus, where it used to be a single click thing.

Is there a way to make Windows 7 stop grouping printers and display them one by one, like XP, Vista, etc. were doing?

Thanks a lot!

Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Devices and Printers, View menu, Group by.


This is not the grouping I mean. I'm referring to the grouping (or coupling, if you prefer) that occurs of printers that connect to the same port. There, only one printer is displayed and if you right click and then hover over the option (e.g. make default) a pop-up window with all the other instances is displayed.

I want to see all instances of such printers listed from the beginning and not in various pop-ups. Just like it was the case in XP and Vista.

I am sorry, I misunderstood you. Searching the internet, I found people complaining and no solution has been found, this is by design in Windows 7.

This is from the social technet.microsoft.com
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

OK, this really appears to be by design although I would think that there should be some way to stop this behaviour, even if it requires registry hacking etc.

However, I have meanwhile found my own way around this: The "consolidation" of printer instances is triggered by the printers using the same port. As only the port name is checked in the consolidation proces and not the address, creating individual ports for each of the printers, pointing them to the same network address, stops Windows from consolidating the printers.

This, of course, only works (easily) on network printers and takes a good bit of fiddling when the printer is connected to USB. (There one may be able to create a new local port that somehow points to the same physical port, but I haven't played with hat - all our printers are network printers and it's trivial to create additional ports here.)


I close the question here, but I hope that a real answer that is better than my workaround is provided from someone else. (In which case I'll gladly open another question so that I can award points to the solution.)
Just to add to this, the grouping also turns off when 'Printing Pooling' is enabled.

So if you have several printers going to the same place, instead of creating a port for each, you can create two ports, and assign both to each printer.
One year later, and I have the same situation and question described by staudte,  but additionally disappointed to be expected to pay for a non-existing expert answer.  There must be a way to turn off this cumbersome feature of Windows 7.  Imagine that, a feature of Vista I prefer over Windows 7.  Meanwhile I'll wait along with staudte for a real answer to a really annoying situation.  29 days to go.

In case anyone else finds this post looking for a solution, Microsoft now has a fix for the issue


Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial