Web Site will not load from the office. How to determine the cause????

emartinson
emartinson used Ask the Experts™
on
The web site www.kcsouthern.com takes "forever" to load inside the office, but outside is pretty quick. When it does finally finish loading, and you select the link for English, the URL below, it will not load. This also loads fine from outside the office. Can anyone help me with the process to troubleshoot? Some testing and config info included below.
www.kcsouthern.com/en-us/Pages/default.aspx will not load from "any" office computer, but from outside the office works fine. I had to load the activeX name.dll, but at the office, the pages never loads to the point where you are prompted to load it. I do have a web filter (iPrism), but even with filtering turned off, or with the site allowed, it will not load. It appears that IMPC is disabled, because I get no response to pinging the site, but a tracert will show the IP of www.kcsouthern.com as 208.29.20.29, but starts timing out at 74.62.124.130.
nslookup displays the ip addresses above. Working from Win XP Pro on various machines with SP2 and or SP3 depending on the machine. Using IE 6 through 8 on the various machines. Tried to connect with Firefox with the same results. As I understand it, this is a SharePoint site, and I have little experience with it. Popup blockers off. Phsing turned off.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi,

Do you use any packet shaping hardware or software? Might be worth running a windows update to ensure you have the latest java, .net framework etc.

Thanks
Tom

Author

Commented:
Tom,
I should have stated this in the orignal question, but I am using the same laptop in and out of the office. It loads the site out of the office, but not in. By packet shaping, do you mean someting like NAT/PAT? The office network goes through a PIX515E firewall and all connections are PAT. Outside is also PAT utilizing a simple Linksys router with firewall enabled.

Author

Commented:
When I posted the question, I had connected remotely to a completely updated desktop at the office, and attempted to load the web page. Now 4+ hours later I checked on it and the page has actually loaded, with these errors found:
Webpage error details
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.2; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Sun, 31 Jan 2010 23:05:16 UTC
Message: 'WPSC' is undefined
Line: 784
Char: 1
Code: 0
URI: http://www.kcsouthern.com/en-us/pages/default.aspx
Message: Object expected
Line: 57
Char: 1
Code: 0
URI: http://www.kcsouthern.com/en-us/pages/default.aspx
Now I tried to open another page from this one, and it acted the same as the original ....
So it does load, eventually, from inside the office, but with errors. It loads quickly without errors from outside the office.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Well, for a large company their website sure is not complient;
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.kcsouthern.com%2Fen-us%2Fpages%2Fdefault.aspx&charset=%28detect+automatically%29&doctype=Inline&group=0

That shows that their are 43 Errors, 61 warnings on the page... still doesn't explain why it won't load however, unless your router is trying to inspect the page and failing due to these errors... but that seems unlikely...

Line 57 is :
<body background="/PublishingImages/bkgd.gif" topmargin="0" marginheight="0" onload="javascript:_spBodyOnLoadWrapper();">

and Line 784 i can't find in that page...

Do you go through a proxy server at work?

Author

Commented:
We do not go through a proxy at work.
I have since found that we can load the site that is actually needed........ Ah, once you find a way to get enough information from the user to actually work on the REAL problem!!!!
Try this site
www.kcsouthern.com/MyKCS/LoginForm.jsp

What is the validator that is referenced from W3 schools? Does it actually test a web page?
Thanks for responding, and I think it is no longer an issue, but I might send their web folks a happy Gram......
The validator is a tool that checks the syntax of a html / asp / php / any web file to check it meets w3c standards.

For example firefox is a lot stricter than IE when it comes to standards complience. It's a tool that can be useful in diagnosing issues with websites, if its from a connectivity side of things or a design side.
I was able to determine with Support assistance from St Bernard Software that my iPrism web filter had a NAT 0 filter exception turned on, and once that was removed, the site loads just fine. Oddly enough, no changes had been made on the iPrism in months, and it had been working without creating any issue until it hit this site..... Maybe due to all the non-complient programming on their site.
I sure do appreciate the responses received.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial