Snow Leopard sharing with Tiger, and Error Code 36

kengreg
kengreg used Ask the Experts™
on
I'm troubleshooting this issue for my neighbor, so (1) I don't have
real-time access to the OS X systems and (2) it's a laid back personal
art studio, not a corporate environment that requires a quick fix.
None-the-less I've been re-visiting the problem for the last month and I'd
really like to offer a valid fix sooner than later.

We have two OS X systems, "Video" on SnowLeopard  10.6.2 and "Gallery"
on Tiger 10.4.  Personal File Sharing worked for two years with the
Video workstation frequently uploading data to the Gallery workstation.  
Personal File Sharing still worked after the Snow Leopard upgrade in November 2009.

Somewhere around late December 2009 users started experiencing network
problems.  It turned out a new wireless device showed up in the neighborhood and
the Video system's Airport connected automatically and anonymously
into the abyss.  I just cleared out the unwanted connections, reconnected
the Airport to the proper network device, and expected everything to work.  Nope.

I reset Personal File Sharing on the Gallery (destination) workstation.  I
first tried to toggle it off, restart, toggle it back on, and restart.
 I could only get as far as the authentication prompt and list of
shares.  I could not actually mount a drive.

I thought maybe system names and IPs were getting corrupted.  I tried
AFP with names.  Then I tried AFP with IP addresses.  I even I used
the wireless router/gateway to setup DHCP reservations.  Nope.  It
didn't matter how I connected I got the same results.  The
authentication prompt takes a password, displays the shares, but I
can't actually mount a drive.

Was the Keychain corrupted on the source computer?  I created a fresh
administrator account on "Gallery" and assigned destination
permissions.   The fresh account with a fresh password allows us the
same access as before, we view the shares, but cannot mount.

In the past I fixed similar issues on school systems.  First I used
Disk Utility to Repair Permissions on the destination, second I used
the hard disk properties to reapply permissions with "Apply to
Enclosed Items".

Here's where I keep getting Error Code -36.  I can't get results from
"Apply to Enclosed Items"  just error code 36.  For starters, Apple
documents this problem in an earlier version of the OS as a Win/Mac
SMB issue.
http://support.apple.com/kb/TS1564

That's not what's going on here; there's no SMB/SIFS, just AFP.  So I
looked up some more recent posts.  Some users report error code 36
while copying corrupted data.  That's not our problem; we are getting
stuck mouting the disk, long before we can copy data.   Snow Leopard
introduced other recent Error Code 36 events, which people have documented,
but the posts seem to focus on Windows destinations or FAT32 drives.

I've never had a system that couldn't "Apply to Enclosed Items".
That's what concerns me the most.  So I've reached the end of my
resources.  What's the real issue here and how do you suggest I repair
it?  Thanks!

-Ken
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
There are a 1000 ways to skin the technology cat.
Commented:
I suggest that you use the Disk Utility and repair permissions on the disk.

If that fails, boot into single user mode by holding CMD+S at startup.  When the prompt appears at the black screen type fsck -f and press enter.  When the process is complete, type exit and the computer will continue to boot. After this, try accessing the share or applying permissions.
Kash2nd Line Engineer
Commented:
instead of using wireless, have you tried hard wiring both the macs and see if that helps.

also, there's a good utility to fix issues available called Onyx. run that and see what the results are.

are both the macs fully updated?

Author

Commented:
Thanks for the ideas; I will try them.  For now I just wanted to clarify that I have a FINDER error code 36.  I did not specify The Finder in my original post:

Tiger (10.4.11) system
Select boot volume, Command I
Expand Ownership and Permissions, Details,
Apply to Enclosed Items
Are you sure... Ok... enter password...
"The Finder cannot complete the operation because some of the data in "Gallery" could not be read or written.  (Error code -36)"

I realized that my original post could be interpreted two ways (1) error code 36 while attempting mount over the network or (2) error code 36 while simply on the finder of the local boot volume.

Unfortunately the network is no longer part of my troubleshooting.  I need to know what's wrong with my local boot volume.  

So here's Disk Utility:
Error: No valid packages

And this is where it leads me
http://support.apple.com/kb/TS2023


Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Kash2nd Line Engineer
Commented:
you could copy basesystem package file from the other system and copy it over to the other machine. and see if that works.

Author

Commented:
Experts Exchange sent me a notice.  Is this an abandoned question?   No, this is not an abandoned question.  

How long can I keep this going?  How can I buy time?


nappy_dThere are a 1000 ways to skin the technology cat.

Commented:
Did you try my suggestions about three posts ago?

Author

Commented:
Yes, thanks "nappy d'.  When I run  fsck -f  in single user mode there are no disk errors.

It will be another week or so before I can visit another Tiger system to copy the basesystem package.  Should I try basesystem from a Snow Leopard system?
nappy_dThere are a 1000 ways to skin the technology cat.
Commented:
The next suggestion I have is that you are to try running a repair permissions when booted from the OS installer CD.

Author

Commented:
Okay, I can run the CD the next time I'm over there.  I was under the impression that File System Check in Single User Mode usually caught the same problems as Disk Utility from the CD.

Eventually I'll need the basesystem package.  I can't see going entirely without it.
nappy_dThere are a 1000 ways to skin the technology cat.

Commented:
The check you ran with fsck does not check permissions, only disk errors.

Author

Commented:
I found a copy of the basesystem package on the wild wild web.  I'm skeptical but it might work
wow, I'd stop fooling around, back up, pave it and reinstall. :-( but that's jus me.

-Best Wishes!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial