How do I set User permissions on public folders in Microsfot Exchange 2007?

ellsworth2000
ellsworth2000 used Ask the Experts™
on
Good Day Experts,

I just finished installing my SBS 2008 server with Exchange 2007 and none of my clients(all are on windows xp sp3) can create a contact within public folders due to permissions.  So I found that i can only add the permissions through the exchange manager shell.  From the technet article I found (http://technet.microsoft.com/en-us/library/aa996369.aspx)

 I'm supposed to run this:
Add-RoleGroupMember -Identity "Public Folder Management" -Member ellsworth2

When I run that the shell tells me the Add-RoleGroupMember is not a recognized cmdlts, program or script file.

Anyone have any ideas on how I'm doing this wrong?  I've enabled the adminstrator account and logged in as administrator just to be sure I have full rights.

Any help would be greatly appreciated, Ellsworth
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
MCSA 2003,

thank you for that article that helps alot though how do I do this part and how do I know what service pack my Exchange server is on?


To perform the following procedure in the RTM version of Exchange 2007, the account you use must be delegated the following: Exchange Server Administrator role and local Administrators group for the target server

Author

Commented:
Also I meant to post this question at 500 points so I just bumped it up to 500.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial