Exchange Error - WARNING: The ISAPI filter was not enabled

zubair010400
zubair010400 used Ask the Experts™
on
Hello Experts -

Creating Exchange 2007 OWA through Exchange Shell Command generates the following error....

[PS] C:\Windows\System32>New-OwaVirtualDirectory -name "owa" -OwaVersion Exchange2007 -WebSiteName "Default Web Site" -InternalURL https://server01.domain.local
/owa -ExternalURL https://mail.domain.com/owa

WARNING: The ISAPI filter was not enabled.
New-OwaVirtualDirectory : An error occurred while creating the IIS virtual dire
ctory 'IIS://server01.domain.local/W3SVC/1/ROOT/owa' on 'SERVER01'.
At line:1 char:24
+ New-OwaVirtualDirectory  <<<< -name "owa" -OwaVersion Exchange2007 -WebSiteNa
me "Default Web Site" -InternalURL https://server01.domain.local/owa -ExternalU
RL https://mail.domain.com/owa

What is causing this error and how can this be corrected?

Thank you.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Please check these are default setting.


check all of your permissions in IIS.

 Default Web site
    Enable Anonymous access
    Integrated Windows Authentication
Exadmin
    Integrated Windows Authentication
    Require SSL
        Require 128 bit
Exchange
    Basic Authentication
        Default Domain \
Exchange-oma
    Integrated Windows Authentication
    Basic Authentication
ExchWeb
    Enable Anonymous access
    Require SSL
        Require 128 bit
Microsoft-Server-ActiveSync
    Scripts and Executables
    Exchange Application Pool
    Basic Authentication
        Default Domain DomainName
OMA
    Scripts Only
    ExchangeMobileBrowseApplicationPool
    Basic Authentication
        Default Domain DomainName
Public
    Basic Authentication
        Default Domain \
    Require SSL
        Require 128 bit

http://support.microsoft.com/kb/323972 

Author

Commented:
Hello - most of these directories under the Default Site does not exist because I failed to mention IIS was reinstalled after Exchange was configured. I have created some of these using Exchange Management Shell but creating OWA generates the error above.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial