Trying to create an Excel RTD Server.

Kinger247
Kinger247 used Ask the Experts™
on
Hi all,

I’m trying to create an excel rtd server, I’ve been messing around with the ms example version at : http://msdn.microsoft.com/en-us/library/aa140061(office.10).aspx?ppud=4
But cant get it to work, has anyone ever tried this or used rtd before ?

When I run the example it starts excel like it should but when you put something like ‘=RTD("Stock.Quote", , "MSFT", "Open")’ in any cell its just says ‘#NA’

Thanks in advance
K.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
If you are using Share Point, maybe you would consider use Excel 2010 & Share Point Server 2010 which "knows" tu use real-time data more easier: Excel Services 2010 Overview

Author

Commented:
No not using sharepoint, I've got the code in place, but cant run it. Tried registering the dll etc, but the example doesnt work.
I know its something to do with the way rtd runs but not sure how.
I've once tryed and also fail to run tha sample (do not remember why / what was the error) - but we consider at that time to use another sollution.

If you still want to try it - maybe this FAQ will help you: Real-Time Data: Frequently Asked Questions especially the error message you are receiving: Why Do I Always Get #N/A When I Enter My RTD Formulas?
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Thing is I have had this running about 18mths ago, but at the time I had to scrap the project for another.
Now I'm back on it, I just cant get it working again. Not sure if I have to register it etc, I'm sure I just copied the code and it worked in debug.

Mind you, that was on XP and now I'm on Vista, so that might be something to do with it.

Author

Commented:
For the record here I've found the solution to this.
It seems that under Vista you need to run the VS as administrator first then open the project from there. I thought as I was admin user it would do that anyway but at appears not.
By doing this the project and example workes fine !

But I'll allocate the points to luconsta for the time spent :)
Thank you Kinger247 for the points - good to know what "suprises" can arise because UAC (User Account Control) - where even user is admin it has to select "by hand" the "run as Administrator" option... to be a "real Admin account"... UAC not always "firing" to let you know you need "elevated privileges"...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial