Avatar of Sci-Fi-Si
Sci-Fi-Si
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Windows 2008 Server - JavaScript problems

I recently had my Windows 2003 Server blow up which was sad. However I now have a new 2008 Web Server - yay!

After taking hours to install I find that wireless networking doesn't work - by default, so got that fixed.
Then I find that URL redirection doesn't work - again by default, now I've got that working to.

However I've installed my WordPress blogs on IIS7 and I find that some drag n' drop functionality doesn't work. It's as though JavaScript is being blocked...

Is this a firewall thing? Is it a default config of IIS7 to disable JavaScript?

How can I get WordPress working like it did under 2003?

Many thanks
Windows Server 2008Web ServersJavaScript

Avatar of undefined
Last Comment
leakim971

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
leakim971

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Sci-Fi-Si

ASKER
Thanks leak,

But that's just for the 'Sociable' plugin. I'm hosting WordPress 2.9.1 on IIS7 under 2008 Web Server. If I install Wordpress on my Windows 7 laptop it works fine, it's just if it's on 2008 that drag n' drop fuctionality doesn't work.

I am speaking to 'esmi' a sys admin at WordPress about this http://wordpress.org/support/topic/362756?replies=9#post-1389728

They say "Could your firewall be stopping/stripping javascript? Your browser? Can  you try using another machine? Another connection? "
SOLUTION
leakim971

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Sci-Fi-Si

ASKER
Interesting, I wouldn't have thought of that one, but alas no joy.


Sci-Fi-Si

ASKER
Thanks for your suggestions leakim971.

I've found the problem!!! I never would have guessed this in a million years - It was a sudden moment of inspiration and it came to me to try this.

It's IIS7's Output Cache! Being new to IIS7 I went through various websites on how to set it up "correctly". However it turns out having the .php extension in the Output Cache is a big mistake.

Thank for your feedback anyway leak

:)

Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Sci-Fi-Si

ASKER
thanks for your help
leakim971

Thanks for sharing your resolution and for the points!