Avatar of olivejar
olivejar
 asked on

Outlook cannot access exchange account after migration

After "successfully" migrating from SBS 2003 to SBS 2008, Outlook 2007 clients cannot access their mailbox.  Users are prompted repeatedly for domain user name and password.

Users can log into the domain
Users can access shares on server
Users CAN send mail via their exchange account.
Incoming mail is properly routed to the mailboxes.

But every time a user tries to access their mailbox on exchange, nothing is refreshed.

I've tried recreating the local profile, no luck.
I've tried with a new account, post-migration, same results.
ExchangeSBSOutlook

Avatar of undefined
Last Comment
Rob Williams

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Rob Williams

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
SOLUTION
Shivtek

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
olivejar

ASKER
I'm not so sure this is my problem, but I'll certainly give them a shot.  Many in the provided links mention "things work just fine except for the repeated nagging to login."  We're not working fine over here.

While it appears that the Exchange Server itself is A-ok, and is receiving mail from the outside, internal users are still seeing their cached mailboxes from when the migration was done.  Even in creating a new, virgin user on the server, while the account data shows there is 1,2,3,4 items in their mail store, the users inbox in Outlook is still empty.

I'll give these a try though and see that comes.
Rob Williams

You may bee right that does sound quite different.
utopianabhi

Check the permissions on Exchange related Virtual Directories in IIS.
Refer:
http://msexchangeteam.com/archive/2008/02/01/447989.aspx
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
olivejar

ASKER
Don't have a solid solution yet, but progress has been made.

So far a combination of disabling cached mode and installing all the latest patches on both server and workstations has helped a bit.  Everyone can finally access their inbox in "real time."

Still getting constantly bugged to log into "remote.domain.com" which was something the Migration Wizard made on it's own.  I know where that came from, just need to track down how to change that.
Satya Pathak

Please find IIS authentication type and the SSL requirement for Exchange 2007.
 
Exchange 2007
 
1) Autodiscover: Basic and Integrated authentication   SSL Optional
2) EWS : Integrated authentication                            SSL Optional
3) Exadmin : Basic and Integrated authentication       NO SSL
4) Exchange : Basic and Integrated authentication      SSL Optional
5) Exchweb : Basic and Integrated authentication       NO SSL
6) Microsoft-Server-ActiveSync: Basic authentication   SSL Optional
7) OAB : Integrated authentication                             SSL Optional
8) OWA : Basic authentication                                 SSL Optional
9) Public : Basic and Integrated authentication          SSL Optional
After that restart IIS and check it.
Rob Williams

"remote.domain.com" is the default connection used by SBS 2008 for access Exchange, RWW, OWA, the self signed certificate, and more. Should you need to change it you can do so by running the "set up my internet address wizard" under Windows SBS console | Network | Connectivity. When doing so on the "Store your domain name information" page click advanced settings and you can change it from the default "remote".
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
utopianabhi

In addition to  authentication defaults, "Default Web Site"/"SBS Web Applications" should have anonymous access and no other auth mechanisms.
olivejar

ASKER
seems a combination of turning off Cache Mode (weird!!!,) updated server and workstations alike, and enabling that Kernal Mode did the trick.

Still need to play around with that Cache Mode not working, but this is good so far.

thank you
Rob Williams

Thanks olivejar.
Cheers!
--Rob
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes