Link to home
Create AccountLog in
Avatar of finance_teacher
finance_teacher

asked on

ORACLE -- 10g on Windows7 ?

Does ORACLE 10g
work on Windows7 32 bit ?

If not, what works on Windows7 32 bit ?
Avatar of ibhavanisankar
ibhavanisankar

It wont work.
The OS version conflicts though it is 32 bit.
Try downloading and using windows xp mode from windows.com and then install oracle on that virtual machine.
However 11g works fine with windows 7 32/64 bit.
Yes it works. You just have to pass the OS version prerequisite check in the installer by manually confirming.

I run both 10g and 11g on Windows 7, so I know it works.
Avatar of finance_teacher

ASKER

I tried installing Oracle 10g on Win7, it seemed to work, I then tested via TOAD & Oracle's Enterprise Manager and it failed.

I then tried to uninstall and got the attached.

How can I fix ?
S011.jpg
ASKER CERTIFIED SOLUTION
Avatar of mrjoltcola
mrjoltcola
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
For me it dint work. so i proposed the solution what i followed.

Actually you have to wait for the Oracle release of 10g for WIndows 7. It is very difficult to work with oracle cd's for other versions of Windows
There is a difference in "certified" vs. "will work". Metalink article 952302.1 says only 11gR2 will be certified.  Oracle has not certified 10g for Windows 7. That doesn't mean it won't work. If you install the Vista version, it DOES work.

I have followed these steps twice on Windows 7, both 32-bit and 64-bit, and have already done one commercial development effort using 10g on Windows 7.
1) Install as Administrator
2) Run DBCA as Administrator
3) Run NETCA as Administrator

As to your uninstall problem above, try running Oracle Installer from the Program menu, using "Run as Administrator". If that doesn't work, you may need to manually remove Oracle.
Avatar of schwertner
What do you mean saying "I then tested via TOAD & Oracle's Enterprise Manager and it failed."
If you can not connect to Oracle thenpossibly either the Listener and/or the Instance was not
started or (more possibly) the instance was not registered by the instance.
Finally be aware that before installing Oracle you have to turn out all firewalls and antiviruses.
And never turn them on ....
I installed  10.2.0.3/10.2.0.4 and it worked in TOAD.

I was then able to uninstall the old versions.
Great, glad it worked for you. Cheers.