Avatar of microscopic_earthling
microscopic_earthling
 asked on

Need help to connect iPhone 3G to D-Link D-2460T Wi-Fi Router

Hello,
    I'm trying to connect my iPhone 3G over Wi-Fi to a D-Link D-2460T router at my home.

The router is setup to offer DHCP and I have 1 desktop and 2 laptops connecting to it. All of them are able to fetch IP+DNS settings from the router. DHCP is configured to dish out IP's in the 10.19.168.x range. The security mode is WEP with a hex key.

The iPhone can detect the network without a hitch and asks me for the WEP key (password) when I try to join. Entering it makes it join the network... but for some reason it's unable to get a IP belonging to the pre-defined range in DHCP. The IP it gets belongs to a completely different segment, i.e. 169.254.186.x. Even the subnet mask isn't the standard 255.255.255.0.. instead it gets 255.255.0.0.

I tried setting a static IP, gateway and DNS settings... but that doesn't help either.

I've even tried dishing out fixed IP's based on the MAC of the iPhone... no avail !!!!

However, when I use the iPhone at my office - it connects fine to the office networks.. there are both secured and unsecured networks there.. and the iPhone connects to both without a hitch...

Has anyone faced a similar situation and managed to figure out a solution?

Thanks,
Sourjya
Wireless HardwareiPhoneDHCP

Avatar of undefined
Last Comment
Alan Hardisty

8/22/2022 - Mon
Alan Hardisty

An IP of 169.x.x.x is a default (I can't get an IP Address, IP Address!).
WEP is the worst possible security you could be using on a wireless router (it can be hacked very easily) and you would be much better off using WPA / WPA2 and then the iPhone won't have any problems connecting.
Having said that - please try the following link which might get you going:
http://www.macrumors.com/iphone/2007/06/30/unable-to-access-password-wifi-networks/
If you can change the Wireless Security to anything other than WEP, i would recommend it, or replace the Wireless box to one that provides better security.
microscopic_earthling

ASKER
@alanhardisty: Thanks for your prompt reply. My router supports both WEP and WPA. So will try the later and get back to you ASAP.

As for that link, I visited the page, but funny thing is I don't get that option to choose the kind of password, i.e. WEP Hex or ASCII... what I get instead is just a simple password entry box.

I'm running Firmware 3.1.3. Has that option been taken off in this version - or is there any other setting elsewhere that'll allow me to modify this?

Thanks,
Sourjya
ASKER CERTIFIED SOLUTION
Alan Hardisty

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
microscopic_earthling

ASKER
@alanhardisty: Thanks a bunch. Switching over to WPA2 managed to do the trick. Based on this suggestion in another site, I tried doing a unsecured joining test by removing all authentication from my router. My iPhone joined without a hitch... next I turned on WPA2 and tried reconnecting. It asked me for the password and joined rightaway.. got the correct IP from DHCP too :D My day's made, thanks to you :)
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Alan Hardisty

Happy Days.  Tip for the Day - Avoid WEP at all costs! ; )
Glad you are sorted - Thanks for the points.