Link to home
Create AccountLog in
Avatar of fyr3byt3
fyr3byt3

asked on

Windows Server 2003 & Adaptec SATA RAID vs USB Floppy

We have a Dell PE SC1425 that has no floppy controller and I cannot find the original OS install disk. When I try to boot into Server 2003 SBS or Enterprise installer, it requires me to use F6 to identify the SATA RAID controller - which I have the drivers d/l from Dell. This works @ the beginning and lets me get through the choose partition section of the install. However, once it begins making a list of "files to copy" it pops up & says to insert the RAID disk driver into A:

I have confirmed its in there & tried a USB floppy drive, along with the emulation recommended by Dell (http://support.us.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R180314&formatcnt=1&libid=0&fileid=245713), both with the same result.

It seems like once the partition setup runs, it loses the USB drive / emulation...
ASKER CERTIFIED SOLUTION
Avatar of Gregory_V
Gregory_V
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of PowerEdgeTech
After it loads the driver, it no longer needs it and will not look for it again.  I've seen this before where a bad floppy was the culprit ... you might try a new floppy disk and/or formatting it before putting the files on it.  

Is this 2003 SBS R2 or non-R2?  and what driver version are you using?  I might also recommend using Dell's installation utility (SBUU) ...

http://support.dell.com/support/downloads/download.aspx?c=us&cs=08&l=en&s=bsdr&releaseid=R131815&SystemID=PWE_XEO_1425SC&servicetag=&os=WNET&osl=en&deviceid=10660&devlib=0&typecnt=0&vercnt=5&catid=-1&impid=-1&formatcnt=0&libid=36&typeid=-1&dateid=-1&formatid=-1&fileid=178694
One other thing ... check the firmware of the RAID and the driver for compatibility.  I have seen situations where the windows installer "doesn't find" the drivers, because they are not compatible.  Most likely this is not the case, and you just need to get a USB floppy drive or do one of the things Gregory V suggested ... but just letting you know that there is that other possibility.

No matter what, you should update both BIOS and RAID controller firmware, particularly Adaptec's RAID firmware, older adaptec RAID firmware has some horrible nasty bugs that can cause it to loose the RAID configuration and such.

Best to update firmware when there is no configuration, so you have nothing to worry about in event the upgrade changes metadata layout and requires the RAID to be rebuilt and destroys data. Some of the adaptec firmware updates require this, so read release notes
Avatar of fyr3byt3
fyr3byt3

ASKER

I tried the Dell USBKeyPrepF6 utility, but still no dice. I am d/l the v4.5 ISO of the server install app to try it...
also you may want to update the bios just to eliminate that being the problem
I tried the v4.5 of the Dell tool, but it said the server wasn't supported. I finally d/l the version 3.1 server assistant & all is good. Thanks for your help.
eh.. 4.5, 3.1...  glad you got the disk downloaded and running ;)