Avatar of NemoNiente
NemoNiente
 asked on

Cisco 2621 VLAN PXE boot setup

I have a Cisco 2621 router with several VLAN's setup on it.  I have ZERO experience with Cisco routers or VLAN's.  Currently VLAN2 has an IP helper address that points to our current PXE server.  As far as I can tell, this is the only place this is setup on the router.

I am trying to change the PXE server to a different IP address and add a bootfile name as well.  What would the commands be on the router to do this?  Do I need to delete the IP Helper address and add the PXE server and Bootfile?

The box we are trying to install is a KBOX from KACE for imaging.  They have told us these two options are 66 and 67, if that helps at all.  Here is the configuration.
Current configuration : 4089 bytes 
! 
! Last configuration change at 13:51:15 MST Tue Feb 9 2010 
! 
version 12.1 
no service pad 
service timestamps debug datetime localtime show-timezone 
service timestamps log datetime localtime show-timezone 
service password-encryption 
! 
hostname DO-C3550-12T-MDF312-07 
! 
logging buffered warnings 
no logging console 
no logging monitor 
enable secret 5 $1$sAeA$7T8HUcoESlznjeXDgYUz60 
! 
clock timezone MST -7 
ip subnet-zero 
ip routing 
ip dhcp excluded-address 172.18.5.1 172.18.5.40 
ip dhcp excluded-address 172.18.5.4 
ip dhcp excluded-address 172.18.5.254 
ip dhcp excluded-address 172.18.5.113 
! 
ip dhcp pool CCUSD-DO 
   network 172.18.5.0 255.255.255.0 
   default-router 172.18.5.1 
   domain-name CCUSD.Local 
   dns-server 172.18.5.10 
   lease 0 4 
! 
no ip domain-lookup 
ip name-server 63.225.234.4 
! 
spanning-tree mode pvst 
spanning-tree extend system-id 
! 
! 
! 
interface Port-channel1 
 switchport access vlan 2 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/1 
 switchport access vlan 2 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/2 
 switchport access vlan 2 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/3 
 switchport access vlan 2 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/4 
 switchport access vlan 2 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/5 
 switchport access vlan 2 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/6 
 switchport access vlan 2 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/7 
 switchport access vlan 2 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/8 
 switchport access vlan 5 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/9 
 switchport access vlan 5 
 switchport mode access 
 switchport nonegotiate 
! 
interface GigabitEthernet0/10 
 switchport access vlan 5 
 switchport trunk encapsulation dot1q 
 switchport mode trunk 
 switchport nonegotiate 
 duplex full 
 speed 100 
! 
interface GigabitEthernet0/11 
 switchport trunk encapsulation dot1q 
 switchport mode trunk 
! 
interface GigabitEthernet0/12 
 description "Connection to CCUSD-DO-Router1" 
 switchport trunk encapsulation dot1q 
 switchport mode trunk 
! 
interface Vlan1 
 description "CCUSD-Admin" 
 ip address 10.41.248.100 255.255.255.0 
 no ip redirects 
 no ip mroute-cache 
! 
interface Vlan2 
 description "CCUSD-DO-Data" 
 ip address 172.18.5.1 255.255.255.0 
 ip helper-address 172.19.5.2 
 no ip redirects 
 ip route-cache policy 
! 
interface Vlan3 
 description "CCUSD-DO-Voice" 
 ip address 172.18.10.4 255.255.255.0 
 no ip redirects 
! 
interface Vlan41 
 description "CCUSD-WAN" 
 ip address 10.41.42.1 255.255.255.0 
 no ip redirects 
! 
interface Vlan52 
 description "CCUSD-DO-Internet" 
 ip address 192.168.2.2 255.255.255.0 
 no ip redirects 
! 
router eigrp 100 
 redistribute static 
 network 10.41.42.0 0.0.0.255 
 network 10.41.248.0 0.0.0.255 
 network 172.18.5.0 0.0.0.255 
 network 172.18.10.0 0.0.0.255 
 network 192.168.2.0 
 no auto-summary 
 no eigrp log-neighbor-changes 
! 
ip local policy route-map DO 
ip default-gateway 10.41.248.1 
ip classless 
ip route 0.0.0.0 0.0.0.0 10.41.42.2 
ip route 10.30.20.0 255.255.255.0 10.41.42.3 
ip route 172.30.10.0 255.255.255.0 10.41.42.3 
ip http server 
ip http port 8888 
! 
! 
access-list 110 deny   ip 172.18.0.0 0.0.255.255 10.41.248.0 0.0.0.255 
access-list 110 deny   ip 172.18.0.0 0.0.255.255 10.41.42.0 0.0.0.255 
access-list 110 deny   ip 172.18.0.0 0.0.255.255 172.18.0.0 0.0.255.255 
access-list 110 deny   ip 172.18.0.0 0.0.255.255 172.19.0.0 0.0.255.255 
access-list 110 deny   ip 172.18.0.0 0.0.255.255 172.30.0.0 0.0.255.255 
access-list 110 deny   ip 172.18.0.0 0.0.255.255 host 10.41.41.1 
snmp-server community public RO 
! 
line con 0 
 password 7 107F282306181E0803087E3E 
 logging synchronous 
 login 
line vty 0 4 
 password 7 073E00764D061506181E5F19 
 login 
line vty 5 15 
 password 7 073E00764D061506181E5F19 
 login 
! 
ntp clock-period 17180181 
ntp server 192.5.41.41 prefer 
ntp server 192.5.41.40 
end

Open in new window

RoutersNetwork Operations

Avatar of undefined
Last Comment
Justin Ellenbecker

8/22/2022 - Mon
that1guy15

Will cisco routers and switches if you want to remove a command 90% of the time you just put "no" and then the command and it removes it.
here is how you would remove the old helper address and add a new one.

int vlan2
 no ip helper-address 172.19.5.2
 ip helper-address 172.x.x.x

!make sure to save your work
exit
exit
wr mem

Open in new window

Justin Ellenbecker

Where is your DHCP server?  Those options are set on the DHCP server in the scope for the range.  Or they can be set as default for the server and are available in all scopes.  Is it a windows DHCP server?
NemoNiente

ASKER
I was under the impression that this router was acting as the DHCP server.  It is the default gateway for all assigned IP's in the network.  Is there a way to know for sure?
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
that1guy15

It looks like your router is setup as a DHCP server with the below config. your IP range that is leased out is 172.18.5.1 - 172.18.5.254.
If you are just changing the address of your PXE boot server then all you need to do on the router is change the helper address command so that the router will pass broadcast between that server and the other vlan.
 

ip dhcp pool CCUSD-DO  
   network 172.18.5.0 255.255.255.0  
   default-router 172.18.5.1  
   domain-name CCUSD.Local  
   dns-server 172.18.5.10  
   lease 0 4  

Open in new window

ASKER CERTIFIED SOLUTION
Justin Ellenbecker

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Justin Ellenbecker

The guide explains how to setup a cisco server to pull auto configs for other cisco devices but the options for the dhcp server should not change.  Otherwise as mentioned the IP Helper will forward DHCP and BOOTP requests to the address of the new PXE server.
NemoNiente

ASKER
The Helper IP address is pointing to a server that is outside that IP range though. It is pointing to 172.19.5.2 as opposed to the 172.18.  Is that going to be a problem?  And if not, is all I need to type to set it all up what you posted?  
ip dhcp pool CCUSD-DO
  bootfile filename
  option 66 ascii tftp-server-name (should be an FQDN and DNS should be available to the dhcp server)

Thanks in advance.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
that1guy15

"The Helper IP address is pointing to a server that is outside that IP range though. It is pointing to 172.19.5.2 as opposed to the 172.18.  Is that going to be a problem?  And if not, is all I need to type to set it all up what you posted?  "
Yes you want it to point to the other vlan. The ip helper command tells broadcast traffic to be sent to that address on the other vlan.
NemoNiente

ASKER
Sorry, but I don't want to mess anything up that is already working.  Once I log in and "enable" what exactly should I type to set it up?
  ip dhcp pool CCUSD-DO
 bootfile filename
 option 66 ascii tftp-server-name (should be an FQDN and DNS should be available to the dhcp server)

Is that all, and exactly all I need to do to make it work?  Thanks in advance.
Justin Ellenbecker

replace filename with the boot filename you are using and then replace the tftp-server-name with your server name, this requires DNS or having it setup in the router.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck