Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

VLANs & VPN

Avatar of cscdubai
cscdubaiFlag for United Arab Emirates asked on
VPN
8 Comments1 Solution1228 ViewsLast Modified:
We have a client site with CISCO 3750 & 3560 switches installed. Data network is on VLAN1, Voice VLAN on VLAN10. We have configured SonicWall 2040 Firewall with X0 interface for VLAN1, and created sub interface for VLAN10 (both on different subnets).
Some Switch ports were assigned to Voice LAN devices (3CX VoIP Server, Patton Gateway,..) with this configuration on CISCO 3750
interface GigabitEthernet1/0/3
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
However, other ports have this configuration on CISCO 3560
interface GigabitEthernet0/22
 switchport mode access
 switchport voice vlan 10
 spanning-tree portfast

We are connecting IP Phones (configured as VLAN10) to any of these ports then connected from the built in switch to PCs.

The gateway for both VLANs is the SonicWall 2040

PCs on VLAN1 can access VoIP Server, and VoIP Server can access Internet through Gateway.

We have multiple remote sites connected by site to site VPN to the SonicWall in HO.
From VLAN1 PCs we can access PCs & Servers on any of these remote sites, but from VoIP Server on VLAN10 we are unable to access PCs in remote sites VPN.

We have checked the firewall and there was a default rule to allow traffic from All LAN Subnets to VPNs, and also we created one to allow traffic from Voice VLAN subnet to VPN subnet but still cannot connect.

Any thing missing??


ASKER CERTIFIED SOLUTION
Avatar of cscdubai
cscdubaiFlag of United Arab Emirates image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 8 Comments.
See Answers