Avatar of nexusfun
nexusfun
Flag for Italy asked on

owa 2007 on iis 7

i renewed the iis certificate after 1 year from the installation and before this OWA on exchange 2007 worked showing me just red X icons when a user logged in.
After this installation OWA 2007 on iis 7 stopped to work or, better, if i digit my https://domain name/owa is not possible to see anything.
i tried to create the virtual directories again but nothing.
anyone knows how to solve the problem?
thanks so much and...sorry for my english.
ExchangeSSL / HTTPS

Avatar of undefined
Last Comment
nexusfun

8/22/2022 - Mon
nexusfun

ASKER
exchange 2007
dexterhome

this sounds like a .net issue i had.
make sure .net 2.0 64 is installed and is the default.
http://support.microsoft.com/kb/894435
make sure IIS is using this version.

Kaffiend

Did you run the "import-exchangecertificate" and "enable-exchangecertificate" cmdlets yet?

This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
nexusfun

ASKER
i created a new self-signed certificate on iis and modified the binding for the certificate...so i was able to connect to the https://... but still i have red x when (like a user) i log on to the OWA.
what can i do?
thanks
Kaffiend

If you use a self-signed certificate, you're going to see that warning.

You should obtain a SSL cert from a public SSL cert provider.  Don't know if GoDaddy works where you live, but they have very reasonable rates.  You could also try certificatesforexchange.com.  Of course, if you have the budget, go for a cert from Verisign.
dexterhome

A UCC cert is best for Exchange - allows upto five names on the cert - godaddy do one - about £50 per year (??$)
If you go this rout then make sure it is configured correctly.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
nexusfun

ASKER
what if i install a CA on my server?
dexterhome

Exchange requires a mulitple support cert to work correctly.
external SMTP requires a public cert authority - not local to machine/doamin.
it will include:
domain name, mail.domain name, sending servername.domain name sending server.internal domain name if different.
Kaffiend

You will have to jump through many hoops to get it to work with a self-signed cert.  

Not worth it.  Invest in the correct cert to save yourself and your team countless hours of frustration and headache.  
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
nexusfun

ASKER
ok...i bought a Digicert UC Certificate for our company...deleted and recreated virtual directories enabled the certificate in IIS7 and exchange2007 (clients access is digicert protected) but the problem is that i see this interface showed in the attachment.
like you see the certificate works but i'm going crazy.
thanks so much for who is able to solve my problem.
owa-issue.jpg
Kaffiend

You mean like this?
http://blogs.technet.com/sbs/archive/2009/06/01/owa-on-sbs-2008-incomplete-corrupt-red-x.aspx

It is a site dedicated to SBS but the Exchange Rollup applies to Exchange 2007, regardless of underlying OS.  (Perhaps when you recreated the virtual directories something got hosed?)
nexusfun

ASKER
thanks kaffiend...i'll try to do that! yes i think exchweb folder was corrupted but what if i install sp2 for exchange 2007?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
ASKER CERTIFIED SOLUTION
Shreedhar Ette

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
nexusfun

ASKER
thanks shreedhar! this was the solution because i already installed it and it works...i think there was a problem with virtual directories that the sp2 solved.