Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

E212: Can't open file for writing - vi Error in Suse Linux

Avatar of F-J-K
F-J-KFlag for Canada asked on
Shell ScriptingEditors IDEsLinux Distributions
6 Comments1 Solution15268 ViewsLast Modified:
Here is my problem:

I installed Suse linux on Virtual Machine. I logged in as a regular user and then switched to root. Afterwords, i typed this command:

#> /usr/sbin/useradd -g oinstall -G dba,oper oracle

In other words, i created a user called Oracle and then switched to Oracle user from root and tried to created .bash_profile from vi. When i do: wq, i get this error:

".bash_profile" E212: Can't open file for writing
Press ENTER or type command to continue

When i type this command q!, i get this error:

E138: Can't write viminfo file /home/oracle/.viminfo!
Press ENTER or type command to continue

After i press enter, vi exits and i get back to the command prompt.

I have no idea why does this happen. Any help/suggestions/advice will be appreciated.

Regards,
F-J-K
ASKER CERTIFIED SOLUTION
Avatar of omarfarid
Commented:
This problem has been solved!
Unlock 1 Answer and 6 Comments.
See Answers