File copy very slow to Windows Server 2008 R2 x64 bit from WinXP/Vista

Murahu
Murahu used Ask the Experts™
on
I am facing very very slow file copy from Windows Server 2008 R2 x64bit

If i copy from server to client it work fast, but client to server is very slow

I have done following task

eliminated all network and just connected directly with the laptop and server and same problem with both gigabit port

did windows update

can someone help me resolve this matter

Thanx
Murahu
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Is the data on your laptop extremely fragmented hence it is taking the laptop a lot of effort to gather the data before transmitting.

Do you experience the same issue if you try and copy data from another client to the server?
Neil RussellTechnical Development Lead

Commented:
Try doing a defrag of the laptop and then send the same file(s). As Krokjky said, it could just be fragmented files slowing it down.
How much slower are we talking here? can you give times in both directions with the same files?
 
2Cs

Commented:
Hi Murahu,

Can you give me more specifics:

-Does this happen with all data you try and copy?
-What speed is the data transferring at (copy the data from the Windows Server 2008 and click more details when you start the copy)?
-What type of data are you copying?
-What HDD configuration do you have?
-What RAID configuration do you have?

Al
Expert Spotlight: Joe Anderson (DatabaseMX)

We’ve posted a new Expert Spotlight!  Joe Anderson (DatabaseMX) has been on Experts Exchange since 2006. Learn more about this database architect, guitar aficionado, and Microsoft MVP.

2Cs

Commented:
I don't believe it would be a defragmented drive causing a copy delay that would be noticeable. If anything it would be a slow disk either on the host or target machine.

Al
MurahuNetwork Consultant

Author

Commented:
I feel its not due to fragmented data, we have tried on all clients on the network and same problem occurs
We get transfer speed of 150KB/Sec for 70MB of file from client to server, for a type of files
Exe Files, Autocad(dwg), etc...
Server is HP DL370 G6 with 146GB x 3 RAID5 confguration

Regards

Commented:
Hi

TCP off loading on the network level may be causing the issue
have you tried disabling it ?

http://support.microsoft.com/kb/951037

Gil
2Cs

Commented:
Providing clients within your network transfer data fast than that (please test to confirm). I would say it would either be a limitation set on the RAID controller check this by going to:

-Start Menu\Programs\HP System Tools\HP Array Configuration Utility

Confirm nothing is set here to limit the rate, you might have to restart the server and enter the configuration of the card during start-up to get full options.

If this is not he case check to make sure the network card is set to auto-detect in device manager.

If you copy a file on the server to another location on the same disk does the data still read slow?

Al

Commented:
is your raid rebuilding or performing a check of some kind?
2Cs

Commented:
You should be able to check the health in the configuration at start-up, it will either report the status or logging into the configuration will show this.

Al
MurahuNetwork Consultant

Author

Commented:
I will try TCP off loading and HP Array Confguration Utility and confirm the change

Data copy on the same disk to other location is fast.

Regards,
2Cs

Commented:
It will be a network related issue then if copying within the same disk is fast.

Good luck! :)

Al
Top Expert 2012

Commented:
TCP Chimney could be causing the issue. Also, What AV are you running? Remove the AV for testing.

Here is another issue that might help.

http://support.microsoft.com/kb/967224
The Broadcom network chipset in your HP DL370 G6 may definitely be a reason to disable TCP Chimney / RSS.

Have a look at network traffic in taskmanager.  Does it suddenly drop off?  Another tell tale sign.  If it's a constant but low rate, there some other cause.
MurahuNetwork Consultant

Author

Commented:
I disabled TCP Off Loading and Large Receive Ofload (LRO) under Device Manager properties and problem was resolved

Thankx for the help

Murahu

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial