Link to home
Start Free TrialLog in
Avatar of DowntownIT
DowntownITFlag for United States of America

asked on

Terminal Server - Default Save Location

I am building a new terminal server and using remoteapp. When a user goes to save the files it defaults to the terminal servers documents folder. I need it to default to the clients workstation or at least Computer on the TS. I can hide the servers drives from there. I saw something about \\tsclient but i am unable to browse thru to it. The reason for this is to make the TS as transparent as possible.
Avatar of Gregory_V
Gregory_V
Flag of United States of America image

A lot of this you can do via policy settings..  For instance Office 2007 save settings:

http://www.kreslavsky.com/2009/01/change-default-save-as-location-for-office-2007-via-gpo.html

Avatar of DowntownIT

ASKER

Unfortunately it isn't office that I am trying to change the default location to. There will be multiple sites connecting so I couldn't static assign the path. I need it to go back to the clients PC
Can I ask what the application is?  Does it have a registry path you can modify?

One thing you could do is to have a logon script run.  It would require the following:

   1. Share drive C on the client as "C".
   2. Connect to the Terminal Services server, and in the session, open a Cmd.exe prompt.
   3. Logon Script with the command:  net use X: \\clientname\C /persistent:yes
C:\ is not "displayed" by default.
Try: \\tsclient\c$
If I type in \\tsclient\c$ I get > Attempt to access invaild address
If I type in \\tsclient > I get a blank window
Sorry, its just \\tsclient\c
But the issue is in your mstsc's settings, local drives resourses must be enabled, check the screenshot.
mstsc.jpg
I am able to browse now thru the \\tsclient\c, I configured under GP to redirect Documents to this link. I verified the GP is being updated but I am still seing the Documents folder on the TS, see attached
Documents.jpg
gp.jpg
After you are logged in, try gpupdate /force
The only explanation I can think of is that group policy applies before \\tsclient option is "initialized".

If noone can find the answer, I will have a chance to try it my myself tomorrow.
tryed gpupdate /force with the same result
Any update on this?
Avatar of Irwin W.
Can you please post the results of these two commands when a user logs in:
  1. GPRESULT
  2. RSOP.MSC  After this report runs, please expand all of the policies so their settings are shown and post them back.

You will need to use GPO to restrict which drives are displayed to hide this.    Refer to the sample code in my FAQ: http://www.tek-tips.com/faqs.cfm?fid=6116 for how to create a custom ADM file to import into your GPO.
nappy - I ran those commands and was able to determin that the GP is processing and working. When I redirect the documents folder to a shared drive, it creates the my pictures ect folders. But when i change this to the \\tsclient\c it doesn't work. The RDP is set to allow local resources and i can browse to it. My exact problem is when someone is running an app and needs to save a report, it defaults to the servers document folder. I would like that to be a local resource on the clients side.

Mark - I have thru GP hid the drives. You cannot see them through  Computer. Yet it still shows the servers documents folder as the default save location.

This could be fixed by training users to find their mapped drives but as you know with users.....

I'd force all users to save their data on the server where it can be backed up rather than having it on their local drives.  Just my 2 cents.
I agree, we have multiple organizations connecting and is not my responsibility to ensure their files are being backed up. They need to save it to a local drive or one of their mapped drives. I was trying to make it simpler for them as I can for see this being a problem.
ASKER CERTIFIED SOLUTION
Avatar of DowntownIT
DowntownIT
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I have the same issue as DowntownIT. Saving the files to the Terminal Server is not an option for us. Our users export data from the Terminal Services Application and need to save the spread sheet to their local drive by clicking on the save button. Would you please help us develop a solution that will save file by default to the users local drive?
I have this same issue using remote app and am looking for a solution.