Avatar of TrevorWatson
TrevorWatson
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Cisco PIX 506 outside access to a machine

This has probably been asked before, but I have'nt been able to find a definitive answer.

I have requirement to access a machine inside our network from outside via the internet.

We have a Cisco PIX 506 on 6.3(5) and PDM 3.0(4) on a line with a range of static IP addresses.

It sits on an outside IP address of x.y.z.42 with the router being x.y.z.41. The inside machine is a.b.c.202 and should respond to ports 4580 and 4599.

If I want to use x.y.z.43 for the outside access to a.b.c.202, what series of commands are required on the PIX?

The inside internet access and outside VPN all work perfectly at present.

Thanks
Trevor
CiscoHardware FirewallsSoftware Firewalls

Avatar of undefined
Last Comment
Istvan Kalmar

8/22/2022 - Mon
Istvan Kalmar

Please show the wqhole config and we tell you the lines that you need!

Please refer this guide howto:
http://www.netcraftsmen.net/resources/archived-articles/369-cisco-pix-firewall-basics.html
http://www.linuxhomenetworking.com/cisco-hn/dsl-pix.htm
TrevorWatson

ASKER
OK here's the config, there is a load stuff in there from some old static VPNs. The last time I tried to remove them them firewall crashed!

Result of firewall command: "sho run"
 
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ******** encrypted
passwd ******** encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.4.2.0 turnhill
name 10.2.1.0 kingslynn
access-list inside_outbound_nat0_acl permit ip any 192.168.3.0 255.255.255.192
access-list inside_outbound_nat0_acl permit ip 10.1.1.0 255.255.255.0 turnhill 255.255.255.0
access-list inside_outbound_nat0_acl permit ip kingslynn 255.255.255.0 turnhill 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any 10.1.1.224 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 192.168.3.0 255.255.255.192
access-list outside_cryptomap_20 permit ip 10.1.1.0 255.255.255.0 turnhill 255.255.255.0
access-list outside_cryptomap_20 permit ip kingslynn 255.255.255.0 turnhill 255.255.255.0
access-list inside_access_in permit ip 10.1.1.0 255.255.255.0 turnhill 255.255.255.0
access-list inside_access_in permit icmp any any
access-list inside_access_in permit ip 10.1.1.0 255.255.255.0 any
access-list outside_access_in permit ip turnhill 255.255.255.0 10.1.1.0 255.255.255.0
access-list outside_access_in permit icmp any any
access-list outside_access_in permit ip turnhill 255.255.255.0 kingslynn 255.255.255.0
access-list outside_access_in permit ip host 217.36.99.43 host 217.36.99.43
access-list outside_cryptomap_dyn_40 permit ip any 10.1.1.224 255.255.255.224
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 217.36.99.42 255.255.255.0
ip address inside 10.1.1.201 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool excell 192.168.3.1-192.168.3.50
ip local pool rcvpn 10.1.1.234-10.1.1.253
pdm location turnhill 255.255.255.0 outside
pdm location kingslynn 255.255.255.0 inside
pdm location 192.168.3.0 255.255.255.0 inside
pdm location 192.168.3.0 255.255.255.0 outside
pdm location 217.36.99.43 255.255.255.255 outside
pdm location 217.36.99.43 255.255.255.255 inside
pdm location 10.1.1.202 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) kingslynn kingslynn netmask 255.255.255.0 0 0
static (inside,outside) 217.36.99.43 10.1.1.202 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 217.36.99.41 1
route inside kingslynn 255.255.255.0 10.1.1.4 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.3.0 255.255.255.0 outside
http 10.1.1.0 255.255.255.0 inside
http 192.168.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-AES-256-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 87.236.130.154
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 87.236.130.154 netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption aes-256
isakmp policy 40 hash md5
isakmp policy 40 group 2
isakmp policy 40 lifetime 86400
vpngroup xlruvpn address-pool excell
vpngroup xlruvpn idle-time 1800
vpngroup xlruvpn password ********
vpngroup RemoteClient address-pool rcvpn
vpngroup RemoteClient dns-server 10.1.1.105
vpngroup RemoteClient wins-server 10.1.1.105
vpngroup RemoteClient default-domain ABC.com
vpngroup RemoteClient idle-time 1800
vpngroup RemoteClient password ********
telnet 192.168.3.0 255.255.255.0 outside
telnet 10.1.1.0 255.255.255.0 inside
telnet 192.168.3.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
management-access inside
console timeout 0
username trevorw password ********* encrypted privilege 5
username iane password ********* encrypted privilege 5
username chrisg password ********* encrypted privilege 5
terminal width 80
Cryptochecksum:7d8371cfc8d5017e4373e1886f9e95cd
: end

Thanks
Istvan Kalmar

HI,

The config seems good, the follwing that enable proxy arp need:

sysopt noproxarp outside
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
TrevorWatson

ASKER
Thanks for that.
I tried the command, then write mem and a reload. However still no joy.
The machine is a video monitoring device listening on ports 4580 and 4599. It works fine from inside the network, but we need an external alarm company to have access.
I can ping 217.36.99.43 from outside but cannot (say) telnet to it.
I must be missing something simple here.
Istvan Kalmar

only this source address allowed from outside:

access-list outside_access_in permit ip host 217.36.99.43 host 217.36.99.43
TrevorWatson

ASKER
Yes that would be what I am trying to achieve. With that address visible outside, routing through to 10.1.1.202 which is the machine I want to 'hit'. Preferrably on ports 4580 and 4599, but anything for the moment!
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Istvan Kalmar

what shows the log?
TrevorWatson

ASKER
I get :
date time 106023: Deny tcp src outside:xxx.xxx.xxx.243/35804 dst inside:217.xxx.xxx.43/4580 by access-group "outside_access_in"

I know xxx.xxx.xxx.243 was my testing source ip address. Interestingly I also have the same message from an 'unknown' source ipaddress. Someone else following this thread?
Istvan Kalmar

but you entered x.x.x.43:
access-list outside_access_in permit ip host 217.36.99.43 host 217.36.99.43


you need :
access-list outside_access_in permit ip host x.x.x.243 host 217.36.99.43
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Istvan Kalmar

and CTRL Z
clear xlate
TrevorWatson

ASKER
Please remember I'm a real beginner on PIX's, but I think the light has come on.
The x.x.x.243 address was the machine I was using to 'probe' my firewall. In the future I will not know the address(es) of the machines that will access in.
Should the command read something like :
access-list outside_access_in permit ip host any host 217.36.99.43 eq 4580
and
access-list outside_access_in permit ip host any host 217.36.99.43 eq 4599
??
ASKER CERTIFIED SOLUTION
nkwizz

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
TrevorWatson

ASKER
Thanks to ikalmar and nkwizz.

The PIX is functioning as required, although it appeared to hang up overnight and required a power off to reset it. Not surprising bearing in mind how much futzing around I've been doing!
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
TrevorWatson

ASKER
Although a solution that would work I implemeted a service group for the two ports to simplify the access-list.
Istvan Kalmar

HI,

Mi comment is aloso good: ID: 26600938, but i didn't cath points:(