Avatar of iband48
iband48
 asked on

Mac OS X 10.6.2 ~ Folder/System Icons Have Vanished.

I'm a relatively computer savvy person. I worked with Windows based systems for most of my life, but switched to an iMac (the first aluminum one before they got rid of the aluminum border around the screen). I'm running Mac OS X Snow Leopard and as of today quite a few folders have vanished.

First off, any actual Folder icon has vanished completely. This applies to the desktop, the finder, and even on the dock. In the Finder and desktop the folder is gone but the text is there, on the dock it is replaced by a question mark. Even diving a bit deeper into the system reveals that a lot of the system files are lacking an icon as well.

I have tried quite a few solutions that I know should work through personal knowledge, as well as a few solutions I've found on various Mac forums based on the issues others have had. The solutions I have tried are as follows:

I) I have logged out/logged in
II) Restarted many times
III) I have repaired the permissions multiple times
IV) I have 'force quit' the Finder multiple times
V) I've tried various terminal commands
VI) I have run various programs to run every maintenance routine I can imagine
VII) I have deleted various .plists that people have suggested
VIII) I have run cache cleaning programs, thinking it was my icon cache

The amount of things I've tried, is the major reason that I've given this question so many points. I even opened up Candybar in a last ditch effort, only to find that the icons that are missing, don't even appear in the program (as though they don't exist).

I also run Windows XP on the side through BootCamp on occasion to work on a website for an old boss of mine. Aside from that, I don't browse the internet or even run any other software.

I understand that in a last ditch effort, I could run the OS X Snow Leopard install disc, but I'm sure you can understand me wanting to avoid it having to come to such a thing. This is part of me not wanting to go through the entire installation process again when I really don't have the time to dedicate to it at the moment; as well, I have been frustrated all day over this. If I can't find an answer, it's going to eat at me.

Thank you in advanced to anyone that responds. I'm willing to try anything at this point. I supplied as much information as I possibly could, hoping to rule out any other possible issues.
Mac OS XApple OS

Avatar of undefined
Last Comment
iband48

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Sigurdur Armannsson

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
strung

There is a suggestion that third party software called iStatPro might cause this problem. If it is installed on this computer, uninstall it.
strung

Also, you could try downloading TinkerTool. You should find an item under "hidden file features" with a check box for "disable desktop features". Click that button on, then off again and see if that solves the problem. (Having it ON will cause your icons to disappear).

strung

This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
strung

Here are three other suggestions from today's MacFixit:  http://www.macfixit.com

First try booting into Safe Mode by holding the Shift key at start-up. When in safe mode, use Disk Utility to run a permissions fix on the boot drive.

Second, try removing the desktop's ".DS_Store" file, which can be done by running the following command in the Terminal application, and then relaunching the Finder (logout and login will do this):

rm ~/.DS_Store


Lastly, try removing the Finder's preference file, which is called "com.apple.Finder.plist" and is located in the

/username/Library/Preferences/

folder.
iband48

ASKER
Unless there is any other suggestion out there, I'm probably going to have to go with the last ditch effort of reinstalling Mac OS X, as sigurarm suggested.

I tried creating a new account on the computer, as it only has mine normally, to no avail.

I downloaded TinkerTools but that did nothing.

I tried the last three suggestions that strung recommended, once again with no actual results.

It was almost funny that you mentioned iStat Pro, as that was in fact the last thing that I installed on my computer before the issues began. I removed it immediately, and once again, the problem persists.

Thank you for your time on this subject, regardless.
Sigurdur Armannsson

Did that cure it?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
iband48

ASKER
Yes. It wasn't the sort of solution I was hoping to go towards.

I ended up just saving all the documents I needed to on a flash drive (since there was only about 7gb worth) and started from a completely fresh install. I'm assuming something got corrupted in the actual icon files, but I don't know for sure.

Anyway, thank you guys for you time and help.