Link to home
Create AccountLog in
Avatar of Playserver
Playserver

asked on

New IP and router for owa and exchange. Can't reach OWA.

I am currently running exchange 2007 with no problems form our T1.  We just had Fios installed and  we are getting rid of the T1 in favor of verizon.  I have not transferred public DNS yet to the new ip addresses because I want to make sure there will be no down time with my new setup.  
I purchased a Netgear Prosafe 338 router and hooked it directly to the verizon ONT through the ethernet connection.(the actiontec router is really bad so I bypassed it entirely).  I have internet connection on a static IP with a block of 13 addresses.  I added port forwarding rules  25, 80 and 443 to my internal exchange server from one of the extra 13 IPs.  I can reach the Netgear 338 for remote admin outside the private network (with port 8080).  I also set up a test machine with just port 80 and reach that from outside as well.(i recieve an IIS HTTP screen).  
But when I try and reach the mail server to OWA nothing.  I am not using a name yet "mail.server.com " beacause of the DNS not being transfer externally yet.  Just IP address.  77.xxx.xxx.xxx.  

Here is what is odd.  Inside the private network if I type the pulbic IP adrress I can access OWA no problems.  That is if I am using the Netgear as my Gateway address for internet access.  If I change back to the T1 gateway and type the new address from verizon, no dice.  I am stumped.

Keep in mind Exchange OWA is already set up correctly and working with my 3com FIrewall and the T1.  I can use "mail.server.com" or an IP address internally and externally to access it.  

Side info:
I am running an ssl cert
The exchange server is still hooked up to the T1 Gateway.
I also tried every Setting with the Provided Actiontec Router with their tech support for two hours and the same results happen.
I hope I explained this as best as possible.
Avatar of LeeDerbyshire
LeeDerbyshire
Flag of United Kingdom of Great Britain and Northern Ireland image

Are you doing all your testing internally?  Not all routers can reflect internal requests for public IP addresses back into the LAN, so if you have two different models of router, then it's quite possible you'll see a difference if all your testing is donw from the LAN.

Ultimately, the best way to see if the traffic is reaching the server is to check the IIS logs, and look for requests coming from the WAN.
"i recieve an IIS HTTP screen"

Any chance of a screenshot / complete discription of this error please
Don't forget, each packed needs not only be delivered to the server but should find it's way back.
Which default gateway has your Exchange server?
Avatar of Playserver
Playserver

ASKER

CaptainGiblets:"i recieve an IIS HTTP screen"
Any chance of a screenshot / complete discription of this error please

The IIS Screen isnt an error. It is the default splash Graphic for IIS to show you it is working. This was just a test to my workstation's internal IP to assure the router was forwarding ports from an external IP correctly.  
I am testing external.  But as I mentioned, internally when I make a external request for my owa(default site) IE 71.xxx.xxx.xxx----->Netgear gateway------>192.xxx.xxx.xxx.  It brings up OWA properly.  If i request from an external Computer....(Not on the 192.xxx.xxx.xxx network).....It wont connect.

So let me ask this...If I change the Exchange servers Default Gateway to the Netgear 338(new verizon Fios) from the existing 3com (T1) I should be able to access OWA externally?  Obviously I would need to do this on off hours not to disrupt current mail transport.
sorry i read it wrong, i thought you meant you received an error message when connecting to owa.

I may be wrong here but... If your trying to connect externally and it sends the request through your Fios, when it gets to the exchange server, and it goes to send its response, it will be sending the reply back through your T1 line as that is its default gateway. So i would say logically the default gateway needs to be changed.

However you might want to check with an expert 1st as my exchange server has always been on the same gateway that owa connects through.
I tried changing the Default Gateway to both the Domain controller and Exchange server to The Netgear 338 (fios) IP and then was unable to access both inside or outside.  
I am stumped still, any other suggestions?  Do I need to turn the 3com firewall off entirely?  I can't imagine that would have any Impact.
ASKER CERTIFIED SOLUTION
Avatar of LeeDerbyshire
LeeDerbyshire
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account