Avatar of ENTPF
ENTPF
 asked on

VMware workstation VMnet DNS uses IPv6

I have the following configuration:
VMware workstation host:  Windows 7
VMs:  Windows 2008, Windows 2008 R2, Windows XP

The VMs are set to use NAT.
When I ping Windows 2008, Windows 2008 R2 by hostname it return the IPv6 addresses.
When I ping Windows XP by hostname, it cannot resolve.
I try pinging with IPv4 addresses, they don't ping back.
When I look at the DNS servers used by the VMnet adapters, they show IPv6 addresses.
What could the problem be that is limited communication to the Windows XP VM?  How can I resolve?
VMware

Avatar of undefined
Last Comment
John

8/22/2022 - Mon
vmwarun - Arun

Are you running firewall or any other security software in the Windows 7 host ?

I suggest that you check the Virtual Network Editor which is found under the VMware Start Menu Program folder for checking as to what Networks have been allocated to each VMnet (0 to 9)
ENTPF

ASKER
No firewall.   I checked the Virtual Netowrk Editor, but nothing explains why I can:

1) resolve ipv6 (windows 2008, windows 2008 r2) but not ipv4 (windows xp)
2)  ping ipv6 (windows 2008, windows 2008 r2) but not ipv4 (windows xp)
John

In order to ping your XP guest by hostname, the firewall of the host machine has to allow the NAT IP range. Typically that won't be the case unless you specifically permit the range. Once you do that, you should be able to ping and connect to the XP guest by name. I can with my Windows 7 Pro machine, VMware Workstation 7 and XP Pro guest (plus other guests). I don't think the IPv6 information that shows up in ipconfig is getting in the way. ... Thinkpads_User
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
vmwarun - Arun

Try disabling the IPv6 option under TCP/IP options of the Virtual NIC of Windows Server 2008 and 2008R2 VM and then try to ping IPv4 addresses.
John

Also, don't forget your XP guest will have the Windows Firewall ON by default.  If I turn that off, I can map a drive on the XP machine from the Windows 7 machine by XP name, so I know that works.

Also let us know about the above suggestion about Server 2008 VM. I don't have this guest, so cannot try it.
... Thinkpads_User
ENTPF

ASKER
thinkpads_user - how do I do what you are talking about?
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
vmwarun - Arun

Run firewall.cpl in the Windows XP VM Run command. This would bring the Windows Firewall Control Panel Applet.
Turn off the firewall and then use the Map Network Drive option to map the folder.
vmwarun - Arun

You can also use the net use command to map network drives.
Do a net use ? at a command prompt.
John

arunraju covered how to turn off the firewall. I use NET USE commands to connect and also Windows Explorer -> Tools -> Map Network drive to connect. Either works.

I also have a corporate Security Suite on my Windows 7 machine where I all the NAT IP ranges (easier than Windows Firewall) and I usually connect from the guest to the host. I can, however, make either way work.
... Thinkpads_User
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ENTPF

ASKER
sorry, i meant how do you do this:
"In order to ping your XP guest by hostname, the firewall of the host machine has to allow the NAT IP range. "
John

NAT is VMware's Network Address Translation tool. It gives an IP range to the guest that is different to the host. So on my Windows 7 machine, the host IP address is 192.168.1.111 and the subnet is .1 . The XP guest machine has an IP address of 192.168.80.128 and the subnet of the guest is .80 . So it is on a different subnet.

Now I mis-spoke earlier by making it sound easy. In order for me to ping my guest machine by name, I must have an entry in my host machine "hosts" file that relates the guest IP to its name. Then I can ping by name. I need the hosts entry because I don't have a DNS server anywhere that will do this for me. My guest machines are all desktop machines and I never needed it.

So I ping by IP address and that works (across subnets).

But without a hosts entry and then by allowing the guest subnet range in my host firewall I *can* connect file shares by name. I can do that both ways.

Further complexifying the issue is that modern Windows systems (XP forward) have built in firewalls that do not allow specifying an IP range. So to connect in, I must temporarily disable the guest firewall. To connect out to the host is no problem because the Windows firewall on the host is disabled and my firewall suite allows me to specify the range.

In all of this IPv6 has no part and creates no problem. .. Thinkpads_User
ENTPF

ASKER
From the windows 7 host, the xp guest cannot be pinged by hostname by ip (at least the ip specified on the guest as opposed to the nat ip that was assigned to it.) from the windows 7 host, the windows 2008 and windows 2008 can be pinged by hostnane and ipv6 addresses are returned.    The  windows 2008 guests can ping the windows xp guest which indicates no firewall on the xp guest.  So any idea why the xp guest cannot be pinged by the host.  
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
John

As I noted, since I do not provide myself a DNS server, I needed a Hosts file entry on the host machine for the XP guest in order to ping by name (it is on a different subnet).

Actually, I have no need for ping by name. I only ping by IP address because I only need to prove connectivity. Once connectivity is established, I need to connect file shares and that I can do. With NAT, I approve the range in my host firewall (Symantec) and that gives me all I need. I work by name with file shares. ... Thinkpads_User
ENTPF

ASKER
I am not pinging the XP guest by hostname.  I am pinging it by IP.  It does not return the ping.  What could be reason?  My guess is because it is using NAT.
These are the IPs:
Guest XP IP:  172.16.10.22
Host Win 7 IP:  172.16.10.170
NAT range:  192.168.163.128-254
ENTPF

ASKER
also, i just tried disabling ipv6 on the the nat vmnet, and now the host can't ping the windows 2008 guests either .
when i re-enabled it, it can ping the windows 2008 guests again.  so the issue seems to be that the windows 7 host only wants to talk ipv6 to guests configured for nat.  if i change it to bridged, no issue. i can ping all the guests (since they are on all the same subnet right now) using ipv4.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
ASKER CERTIFIED SOLUTION
John

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
ENTPF

ASKER
It was confgured for NAT, but...172.16.10.22 is what I specified as the static IP.  If I change it to DHCP, it will pick up 192.168.163.128.  So this is starting to make sense.  I set static IPs for all guest.  The XP was not working because it had a static IPv4 IP already configured.  The windows 2008 guest worked even though they had ipv4 static ips because their ipv6 setting were set to DHCP (default).  So now the winxp is using 192.168.163.128, and i still can ping it from the win 7 host.
John

Given your comments, I think your networking is the issue rather than IPv6. Standard networking still uses IPv4 for the most part as far as I can see. I do not disable IPv6 and nothing goes wrong because of it. I did not see (went back and quickly looked) that you were using a static IP on your XP guest. I always use DHCP for my guests as that will always pick up the right IP.

So is this now clearing up for you? and it appears you have the connectivity and ping you were looking for?  You still have to be much aware of host and guest firewalls as you work because they can get in the way if you are looking the other way.

.... Thinkpads_User
John

Thank you, and best wishes in your endeavours. ... Thinkpads_User
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.