Avatar of dbasplus
dbasplus
Flag for Australia asked on

Joining XP Pro SP3 Workstation to SBS2008 Domain

I'm setting up my first SBS2008 network (after setting up loads of SBS2003 networks for years), and I can't seem to get any workstation to connect properly. It's as though the server isn't assigning a DHCP IP address to the workstations.

If I manually assign an IP to the workstation then I can ping the server, but only by IP, not name, even when using the server IP as the preferred DNS on the workstation.

As this is my first attempt at SBS2008, I installed everything as default. The server is an HP Proliant ML350 with 160GB HDD and 6GB RAM. Workstation is Intel Dual-Core 2.6Ghz, 2GB RAM, 320GB hard disk, with a fresh installation of XP Pro with SP3.

All the usual services appear to be running and I can't see anything obvious in the logs.

As I'm still finding my way around SBS2008 I'm hoping someone can show me the silly mistake I've made that is stopped this simple process working.

Below is the ipconfig /all from the server:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : SERVER01
   Primary Dns Suffix  . . . . . . . : mydomain.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : mydomain.local

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
   Physical Address. . . . . . . . . : 18-A9-05-3E-14-AC
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::85cc:7d83:4028:a51e%10(Preferred)
   Link-local IPv6 Address . . . . . : fe80::bf1a:44ee:119d:8bfa%10(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : ::1
                                       127.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 8:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : isatap.{E3CB938B-6156-4BC7-840D-E5A766857570}
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Thanks.
SBS

Avatar of undefined
Last Comment
Rob Williams

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Rob Williams

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Rob Williams

The client should also have only 1 NIC enabled until after joining the domain.
Also in case you are not aware http://SBSname/connectcomputer  is now http://connect  with SBS 2008
SMBGUY

ipconfig /all from a  workstation woulkd also be useful to see
SMBGUY

from a workstation execute nslookup server01.mydomain.local and post the result?
Substitute your FQDN please
Your help has saved me hundreds of hours of internet surfing.
fblack61
dbasplus

ASKER
Ah thanks! It was the "Connect to the Internet" wizard which did the trick. I had assumed I could leave that until later, when i was ready to connect to the internet.

It seems it should be called the "Connect to the internet and setup my network" wizard instead!

Thanks again.
Rob Williams

Thanks dbasplus. The connect to the Internet wizard completes the DNS sett up, which is likely why it didn't work.
Glad to hear you are up and running.
Cheers!
--Rob