Avatar of Arikael
Arikael
Flag for Switzerland asked on

can't get activesync to work

Hi experts

I'm trying to get my activesync to work via testexchangeconnectivity.com.
I already tried the guide here: https://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

But there is a strange problem which is somehow security related I guess.
According to it-eye the virtual directory "Microsoft-Server-ActiveSync" only needs basic authentication.
This does not work for me. Whenever I only enable Basic-Authentication I get the following error from testexchangeconnectivity:
Attempting to send OPTIONS command to server

       Testing the OPTIONS command failed. See Additional Details for more info
       
      Additional Details
       A Web Exception occurred because an HTTP 401 - Unauthorized response was received from Unknown

As soon as I enable "integraded authentication" the process completes with a warning that I use unsupported authentication methods ->
See here: http://technet.microsoft.com/en-us/library/dd439361%28EXCHG.80%29.aspx

I assume this is way my ActiveSync on Symbian does not work but I have no idea why this happens and what could cause it.
ExchangeMicrosoft IIS Web Server

Avatar of undefined
Last Comment
Arikael

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Glen Knight

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Akhater

What Exchange Server are you running on ?

make sure the user you are testing is not an administrator
Glen Knight

If you are using Exchange 2007/2010 then using Active Directory Users and Computers from the View menu select Advanced Features.
Then the user you are using to test with right click and select properties then under the Security tab click Advanced.
Under here ensure the check box for "allow inheritable permissions" is checked and click OK.
Akhater

Exactly my point :)

However you will need to remove it from any AD protected groups before (Domain Admins, Administrators, schema admins ...) before or else the permissions will be overwritten shortly
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Glen Knight

Never noticed that and my account works fine after entering the allow inheritable permissions
Akhater

Arikael

ASKER
thanks for your answers:

I always did a iisreset after I changed something in IIS and I followed the it-eye tutorial.
However, I'm not sure what I have to use for REALM and DOMAIN (in virtual directory). Do I have to use the data of the server or my public available data. Which is not the same.

I'm running Exchange 2003
The user is only member of Domain-Users
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Glen Knight

It needs to be your internal domain name.
Arikael

ASKER
ok, so now I have (following it-eye)

Exchange
domain: myinternaldomain
realm: myinternaldomain.local

MSAS
domain:myinternaldomain
realm: myinternaldomain

the domain I use for testexchangeconnectivity is also my internal one like
myinternaldomain.local\testuser

is that correct?
Glen Knight

yes correct now run the tests again.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Arikael

ASKER
is still got this error:

Attempting an ActiveSync session with server
       Errors were encountered while testing the ActiveSync session
       
      Test Steps
       
      Attempting to send OPTIONS command to server
       Testing the OPTIONS command failed. See Additional Details for more info
       
      Additional Details
       A Web Exception occurred because an HTTP 401 - Unauthorized response was received from Unknown

When I use Integrated Authentication on MSAS it works...

I already crosschecked all my settings with it-eye, can't find anything wrong.
Glen Knight

Do you have forms based authentication turned on?
If so can you turn it off and then try again.

Is this a Small Business Server?
Arikael

ASKER
no, it is turned off.

I also made sure, that "activate unsupported devices" is checked and that I don't force the devices to use a password.

yes, I'am using a Small business Server
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
SOLUTION
Alan Hardisty

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Arikael

ASKER
Hi

thanks for your inputs

When I came to the office today, I rechecked all my IIS settings (but didn't change anythign) and called iisreset just to be on the safe side.
After that I checked my connectivity with testexchangeconnectivity using myinternaldomain\user instead of myinternaldomain.local\user and everything worked...

So I re run the test using myinternaldomain.local\user and it worked too.

I have no clue what the problem was.
Could it be that it takes sometime until changes I made in the exchange-server manager have effect? (I unchecked "devices need password", but that was yesterday, see comment ID 26821000.

Glen Knight

Well that's a good thing.

It can take upto 2 hours for permissions in Exchange to take effect but it wouldn't normally effect IIS

the main thing is it working.
Alan Hardisty

Agreed - good news it is working and the magical change that made it work may never be known but hopefully my Article / FAQ that Demazter / I posted will have been helpful.
If you didn't run iisreset yesterday, and made changes, then that is probably what made the difference.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Arikael

ASKER
Hi

Without your FAQ my ActiveSync wouldn't run at all, it was very helpful. thanks.
"stupid" symbian doesn't work yet, but that's not really important, as all our customer use Windows Mobile or iphones and testexchangeconnectivity and accessmylan work.

great help, thanks
Arikael

ASKER
thanks!
Alan Hardisty

Not used a Symbian phone (yet), but may get one for testing purposes, then I can offer a broader solution (hopefully).
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
Arikael

ASKER
@everyone with similar problems.

You definitly should read all the comments and all links, not just the one I marked as solution.
They are all very helpful and might solve your problem.