Avatar of Clodo28
Clodo28
Flag for France asked on

Terminal Server Licensing detection

Hi,

I have a 2003 server using TS per users CAL which licenses are located onto another 2003 server.  I am currently changing the License Server. I am trying to make it point onto a new one. To achieve this I need to change the detection mode from automatic to manual. Unfortunately, in the TS parameters this option is grayed even if logs with Admin rights.
This option was available onto all the others servers I migrated to this new licese server.

Many thanks for your help.  
Windows Server 2003Microsoft Legacy OS

Avatar of undefined
Last Comment
Clodo28

8/22/2022 - Mon
RustyZ32

try it manually as follows:

on the terminal server, open the registry editor (start - run - regedit)
navigate to:  HKEY_LOCAL_MACHINE/Software/Microsoft/MSLicense/Parameters
modify the key "enterpriseservermulti" and under the value put the name of the new icensing server.



Henrik Johansson

As it's grayed out, there's propably a GPO configuring the setting and will disabling local configuration through MMC or registry.
Use RSOP.msc to locate what GPO is configuring the setting and use GPMC.msc to edit the GPO
Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Use the specified Terminal Server License servers

TSLS can be configured through either GPO, local MMC or registry as described in http://technet.microsoft.com/en-us/library/cc737644(WS.10).aspx

As the question is in Windows Server 2003 zone, you may miss GPMC (better tool for GPO management compared to ADUC) downloadable from MS.
http://www.microsoft.com/downloads/details.aspx?FamilyID=0A6D4C24-8CBD-4B35-9272-DD3CBFC81887&displaylang=en
Clodo28

ASKER
I also need to change the Licencing mode from Per User to Per Device. It is also unvailable, is the following registry entry can be used to change the Licence mode?

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\Licensing Core\PolicyAcOn

Form 4 to 2

Regards,
Your help has saved me hundreds of hours of internet surfing.
fblack61
ASKER CERTIFIED SOLUTION
RustyZ32

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Clodo28

ASKER
Worked fine. I did not remind that I forced the setting by local GPO.