Link to home
Start Free TrialLog in
Avatar of Scripting_Guy
Scripting_GuyFlag for Switzerland

asked on

Make explorer ignore desktop.ini or disable creation of desktop.ini in Vista/7/2008

Hi,

I have this very annoying proglem. We are using network drives as Home-Dirs for our users. This has never been a problem, before upgrading to vista and server 2008 in some offices.

The Vista / 7 client will create a desktop.ini file in the Home-Directory, in which it states that the directory is a My Documents-Dir. The Home-Directory with the desktop.ini is stored on a server 2008. I have a folder on my server containing all user home directories (d:\Homes). The home directories are named after their usernames, so the actual foldernames are d:\homes\user1, d:\homes\user2 and so on.

Because server 2008 takes a peak into those directories and reads the desktop.ini, it realizes that the folder is a My Documents folder. Therefore, explorer will name the folder "documents" (server 2008/vista) or "My Documents" (server 2008 r2/windows 7). This might be a nice usability thing if you just have one folder. However, in my case, my folder d:\homes contains only folders named "Documents". I've added a screenshot which will hopefully clarify what i mean.

Obviously, this is very annoying, as I have no idea which directory i'm looking for if i want to navigate into a users home-directory using a vista / win7 / server 2008 client.

Is there a possibility to
- let explorer ignore the desktop.ini in the folder and display the actual folder name
or
- prevent the creation of desktop.ini (with a gpo or something like that)

or do you have any other ideas how to solve this?

many thanks in advance!
homes-dir.JPG
ASKER CERTIFIED SOLUTION
Avatar of JonLambert
JonLambert
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Scripting_Guy

ASKER

perfect answer, thx for the kb link