We help IT Professionals succeed at work.
Get Started

Subinacl problem is assumes HKLM

1,233 Views
Last Modified: 2012-08-14
Subinacl problem is assumes HKLM , it seems that when I run a command it assumes that I am looking for some regkey in HKLM but what do I have to do if I want to change a key in HKU ?

For example

subinacl /keyreg \System\CurrentControlSet\Services\SNMP\Parameters\PermittedManagers /grant=administrators=F

this works without defining the HKLM

this is the result

Elapsed Time: 00 00:00:00
Done:        1, Modified        1, Failed        0, Syntax errors        0
Last Done  : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SNMP\Parameter
s\PermittedManagers

C:\>

See the it assumes HKEY LOCAL MACHINE

But if I put in a HKU key this is what I get


Elapsed Time: 00 00:00:00
Done:        1, Modified        0, Failed        1, Syntax errors        0
Last Done  : HKEY_LOCAL_MACHINE\HKU\Software\Microsoft\SystemCertificates\Root\P
rotectedRoots
Last Failed: HKEY_LOCAL_MACHINE\HKU\Software\Microsoft\SystemCertificates\Root\P
rotectedRoots : 2 The system cannot find the file specified.

It adds in HKLM  how can I change this
Comment
Watch Question
Commented:
This problem has been solved!
Unlock 1 Answer and 5 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE