Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Exchange 2007 CCR problem : Error on Get-StoragegroupCopyStatus

Avatar of seb_acker
seb_ackerFlag for France asked on
Exchange
2 Comments1 Solution1298 ViewsLast Modified:
Hello All.
It's my turn to face something hard to solve ;)

Have Just setup a new CCR in an existing 2007 environnement.
The CCR is Sp2.
During setup, the databse did not mount.
I runned setup.com /newcms again, and the setup finished.

The only thing i noticed is that in my cluster resources, i don't have any http virtual server rinstance that has been created.... But no error in my setup log concerning that step. I assume that this resource does no more exist in a CCR Sp2 ?

 Without any further step after the intial setup (no new databse, no specific configuration, and son on...), i just have the default first storage group enabled for replication.
The database is well replicated, the cluster is moving form one node to another, without any problem.

When asking Get-StorageGroupCopyStatus form node2 (the second one i installed), this command is working, wheter the Node2 is active or passive.
When askting the same command from Node1 AND (only If) node1 is Active, i get this error :

------------------------------
The following error(s) were reported while loading topology information:

get-StorageGroupCopyStatus
Failed
Error:
Microsoft Exchange Replication service RPC failed : Microsoft.Exchange.Rpc.RpcException: Error 5 from cli_GetCopyStatusEx
   at Microsoft.Exchange.Rpc.Cluster.ReplayRpcClient.GetCopyStatusEx(Guid[] sgGuids, RpcStorageGroupCopyStatus[]& sgStatuses)
   at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.InternalGetCopyStatus(String serverName, Guid[] sgGuids, RpcStorageGroupCopyStatus[]& sgStatuses, Int32 serverVersion)
------------------------------

If i'm going through the GUI, same behavior, but of course a graphical error ;)

Using TEST-REPLICATIONHEALTH, the command fails (only from node 1), at the "ReplayService"  step, with a slightly different error, and that wheter the Node1 is active or passive :

Test-ReplicationHealth : Microsoft Exchange Replication service RPC failed : Microsoft.Exchange.Rpc.RpcException: Error 5 from cli_GetCopyStatusEx   at Microsoft.Exchange.Rpc.Cluster.ReplayRpcClient.GetCopyStatusEx(Guid[] sgG
uids, RpcStorageGroupCopyStatus[]& sgStatuses)
   at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.InternalGetCopyStatus(String serverName, Guid[] sgGuids, RpcStorageGroupCopyStatus[]& sgStatuses, Int32 serverVersion)
At line:1 char:23
+ Test-ReplicationHealth <<<<
    + CategoryInfo          : ReadError: (:) [Test-ReplicationHealth], ReplayServiceRpcException
    + FullyQualifiedErrorId : FAAD1E2E,Microsoft.Exchange.Monitoring.TestReplicationHealth

I already Googled a lot but was not able to find a "solution" or an explaination

Checked that i have no watermarks indicating that the cluster is not finished to seutp.
CUninstalled everything / reinstalled after complete cleaning of dirctory, registry, ad, and ADSIEDIT.

The fact is that everything else seems to work (i created other databases, moved them, suspended everything then resumed, hard crashed the cluster, and so on....Nothing specific to notice...)




What would you do more ?
Thanks a lot
ASKER CERTIFIED SOLUTION
Avatar of seb_acker
seb_ackerFlag of France image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 2 Comments.
See Answers