We help IT Professionals succeed at work.
Get Started

sqlplus "/ as sysdba" not working as expected

jrDBA
jrDBA asked
on
4,505 Views
Last Modified: 2013-12-19
I am attempting to kick off a sql script as follows:
sqlplus "/ as sysdba" @scriptname
 
...and getting:
ERROR:
ORA-01031: insufficient privileges

I have tried re-creating the password file.  I can log on to the db via both sys/system w/wo sysdba with the same pw.

Odd thing is that this works fine on one of my servers, but not on the one I am having the problem with.  The os user in this case is a member of the "dba" group as well btw.

Any thoughts?


 
Comment
Watch Question
This problem has been solved!
Unlock 1 Answer and 13 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE