We help IT Professionals succeed at work.
Get Started

Problem with index and query performance

hidrau
hidrau asked
on
237 Views
Last Modified: 2012-05-09
Hello guys

I have a table with 500.000 rows
I have a field named LN_datahora that is datetime
I have for this field an index

When I run my query with SHOWPLAN_TEXT ON, so that I can take a look at the plan,
I noticed that the index is not being used,

This is the result when showPlan returns the information:

  |--Table Scan(OBJECT:([REPLICADOR].[dbo].[linhacomando]), WHERE:([REPLICADOR].[dbo].[linhacomando].[LN_DATAHORA]>='2010-01-01 00:00:00.000' AND [REPLICADOR].[dbo].[linhacomando].[LN_DATAHORA]<='2010-03-11 00:00:00.000'))


As you can see, it is being done a SCAN without index
Why?

This is my index : nonclustered located on PRIMARY- LN_DATAHORA
Comment
Watch Question
CERTIFIED EXPERT
Top Expert 2011
Commented:
This problem has been solved!
Unlock 1 Answer and 7 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE